"Please turn on roaming data" message -- but my roaming is already on

Phone: Galaxy S7
Plan: My Choice + 1G

Ever since I installed updates on my phone in early November, I’ve been receiving a message to turn on roaming data. However, I’ve checked repeatedly and every time I’ve already had roaming data turned on. This only happens when I’m traveling in areas with a poor signal. How can I stop this message from showing up when it doesn’t apply?

Not really a solution to your problem but you can suppress that notification from the Republic Wireless App…by going to
Settings -> Advanced Settings-> Disable “Show Roaming Disabled” option

Please go to Settings
Connections
Mobile Networks
Check that all boxes are switched on
Then go to Roaming Guard - it’s called something else now, I don’t use my S7 any more so not sure of the exact name…
Uncheck all the boxes

As long as Roaming Guard or what used to be called that is turned on you’ll get that warning message.

1 Like

@ashleyr Are you still having this issue?

No, my phone installed some more Android updates about a week ago and I haven’t had the problem since then.

Great to hear!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer