Poor experience with strong wi-fi and weak cellular service

What phone do you have? Motorola Moto G6

What plan are you on? $20 voice and data

Does your plan include data, or just talk & text? includes data


I have a strong wi-fi signal when at home, while my cell service is very weak anywhere in my house. But occasionally, perhaps one in five outbound calls, my phone chooses to place the call over the cell service with predictable bad performance. I can’t seem to find a setting that will tune the RW app to favor strong wi-fi over weak cellular. It makes no economic difference to me, but I want to use my w-fi when I am home. RW should know this already.

I can mitigate the situation by enabling airplane mode and then re-enabling my wi-fi, although the phone usually chooses the 2.4 GHz instead of 5 GHz and I would also like to fix that setting.

Have you experienced similar behavior? Do you have a better fix? Is it time for me to explain this to RW and see what they can do?

Hi @kwe!

Welcome back!

As far as the Wi-Fi calling issues go, see this thread and follow the steps from Southpaw’s post: Can't make calls over WIFI only cell even when on my home WIFI network and I have data via WIFI . Let us know if that helps your situation at all.

As far as the 2.4 Ghz and 5 Ghz WiFi issues, you should be able to fix that by having separate SSIDs (names) for each frequency. You should be able to login to your router’s interface via your browser and change it from auto-determining 2.4 or 5 Ghz to having them split off (for example, Network and Network_5G). That way you can explicitly choose the 5Ghz network. Your username, password, and the IP address to login should be on your router provided by your ISP ( the IP will probably be something like 192.168.1.1 or 192.168.0.1). If you tell us your ISP, we can probably help you find the setting to split them off if you would like.

I hope that helps!

1 Like

In addition to the direction that @mb2x pointed you towards, we all need to consider that some of the problems we are experiencing is caused by the fact that all of our neighbors are probably at home and the ISP’s are being heavily used. I checked earlier and my 1 Gig fiber was running about 30% slower than normal … using Speed Test by Ookla

1 Like

That advice doesn’t seem to apply, but I found a Tips article (that I can’t find now) about Android doze mode. If my phone is in doze mode, the wi-fi is off and incoming calls over wi-fi don’t work and I get cell calls. But I still sometimes make calls when wi-fi should be available and RW uses the cell service. Perhaps it takes a few dozen seconds after waking wi-fi for the RW app to re-establish VoIP.
I installed MacroDroid and a template to prevent doze mode from disabling wi-fi. We will see if that works.
As for wi-fi band, I have named the two bands with two different SSIDs, but I can’t find a setting on the phone or the router to prefer one over the other.

Thanks. We should all endeavor to persevere.

Hi @kwe - is this by chance the Doze Tips & Tricks article? Just in case you need it for reference.

What I did was just forget the 2G one. Thus, it only connects to the 5G band. Of course, I have access to a mesh network so coverage isn’t a problem with 5G. I am unsure of your situation, but you can give that a try.

Thanks, that’s the one and now everyone reading this thread has the instructions that I used to try it out.

If the MacroDroid stops doze mode and that fixes it, then I won’t need to be toggling airplane mode and wi-fi, but forgetting the one I don’t want is the best solution, although I would prefer a preference metric that Android doesn’t have.

Any feedback on the effectiveness of the MacroDroid fix? It has got this far based on multiple users with different phones and WiFi providing info that has made corrections/additions.;
Thanks

I think it is helping but there are still times that my phone reports “Emergency Calls Only” which a restart will fix, but the RW app won’t.
I did have one time only when I made a call and it used the cell service while I was in the same room as the wi-fi, so the situation is better, but I don’t trust the way RW is handling cell versus wi-fi.
It would help if the RW app would report more information in the form of notifications about the status of its connection.
RW app Diagnostics always reports everything is fine.

I just checked my Recent Notification log, and see quite a few instances that the current Macrodroid does not check for.
Your “Emergency Calls Only” is not something that I can touch via the app, but have added changes to my app for the instances that I found … Still under test and will publish it, after running for a period of time and insuring no adverse effect.

Do you know if T-Mobile or Sprint has better coverage in your home? The easiest solution might be to ensure you are using the best cellular partner for coverage in your home.

“Due to the fact that we are backed by two of America’s largest 4G LTE networks we’re able to resolve many coverage issues through a help ticket and by analyzing your current configuration and location information.”

If this is so, then give me a software switch on my phone to select the other network. Don’t ask me to send you three physical addresses where the first network doesn’t work. This is moronic and a classic ploy to reduce help tickets.

So if, “a classic ploy to reduce help tickets” is what you would call a request for information that allows them to make an informed decision on switching to the other carrier … then your right.
Essentially the coverage maps that the carriers provide are based on engineering data that was used to place the antenna’s. With the information of 3 addresses that are important to you, they can then do a better job of carrier matching.

Hi @kwe,

It may seem moronic, but we aren’t able to provide the option to switch on the fly. Your phone can be outfitted for coverage on only one of our two cellular partners at a time. So we need to make sure we wouldn’t be making your coverage situation worse before sending you a replacement SIM card to move you to the other provider.

We’re actually doing more work and handling more tickets by making this option available to our members, not less work/fewer tickets.

2 Likes

OK, so I installed the MacroDroid Android app to keep my Moto G6 from going into Doze Mode. Did that help? I think so, but yesterday I picked up the phone and dialed my Dad on “Republic Network”. He didn’t answer in time (old) so I redialed on – surprise-- “Cellular Network”. I hung up and redialed and got “Republic Network”.
Doze Mode is bad, but so is your app.

As I don’t have a Moto G6 and being the author of Doze Detect 0.9.6.5 it might be helpful if you go into your MacroDoze, and pull a snippet of the User Log. The app provides the ability to ‘share’ via various sources, I have been pulling logs on my test phone and emailing them to myself … then it’s easy to trim to the time you experienced the failure and provide that as feedback. Who knows, I might be able to figure something out, as at this time I am at a loss.

Message an
Expert customer