Port issues and supposed incorrect zip code

What phone do you have?
Google pixel 4
What plan are you on?
4.0
Does your plan include data, or just talk & text?
Yes

Issue Description

First off I have a ticket in that’s been escalated to the engineers but it’s been over a week so I’m attempting to find answers on my own if I can.
My problem is that I’ve tried to port my number to 2 other carriers and both have said the zip code was incorrect. This was also the case a year ago. Ive verified both with customer support and my account page that the billing and service zip are indeed correct. Apparently when I ported my number over to RW years ago a different zip was used to activate my account, but no one appears to know what that is.
I’ve even tried using RW headquarters zip in Colorado. As well as my 4 previous address zip codes. All ports have failed.
So it appears I’m stuck with RW. That being said as a 4.0 legacy plan holder I’ve tried to activate a 5.0 SIM into my new pixel 5 with a different account holder name (This is a recommended RW workaround) and I receive the error my number cannot be ported.

Any suggestions on how to proceed?
I fear this is going to take weeks.

Hi @lynne and welcome to the Community!

It is not my intent to argue with your experience, however, theoretically, porting a Republic number should never be rejected due to an incorrect zip code. This is because, Republic doesn’t validate the zip code one gives to another provider when porting out. Republic validates only the account number and PIN.

Yet, I note the mention of multiple instances of ports being rejected due to an incorrect zip code. Let’s try something. Without sharing it, please enter your Republic phone here: You are being redirected....

Who is the carrier?

I have no clue what this means but Im intrigued!!
This I believe is not the main issue but an additional issue that may of been caused by my multiple attempts at porting.
FYI I’ve had my number since 1997. So it’s been ported many times.

Hi @lynne,

Without leading you too far into the weeds, that Level 3 is the carrier for your Republic number is the source of your porting woes. I apologize, I seem to be the first to have pursued this.

Generally, Republic numbers on My Choice and earlier plans are hosted on Bandwidth’s network but a few are hosted with Level 3. When porting a Republic number hosted with Level 3 if I remember correctly, one needs to use the zip code for Level 3’s corporate office. Please allow me to verify that. I would like to minimize any further porting issues for you.

1 Like

That doesn’t surprise me.
I had been told previously to enter a RW corporate office zip in Colorado.
Zip 80021?

As you’re probably aware, Republic has been acquired by DISH Wireless, LLC who is indeed headquartered in Colorado. Candidly, the support folks in Colorado aren’t yet fully versed in all matters related to what are now considered legacy Republic plans.

May I know how you’ve been communicating with Republic support? Did you call them as the port failure message you received when attempting to activate on 5.0 would have suggested?

Have they opened a ticket on your behalf? Do you have a ticket number?

I started corresponding with customer support via help ticket/email 58 emails ago…on the 18th.

Ticket 2193887

1)It started off as a porting failure ticket/zip code issue.

2)Now in addition to that, once I got my 5.0 SIM this weekend, it’s an unable to upgrade to 5.0 plan also. Here is the screenshot message. “YOUR PHONE NUMBER IS NOT ELIGIBLE FOR PORTING.”

BTW…who are you?
I’ve made more progress with you in 5 mins than I have in a week with multiple people handling my ticket.
You’re amazing!

1 Like

I’m a fellow Community member and Republic Community Ambassador. I’m also one of Republic’s Expert Customers: https://help.republicwireless.com/hc/en-us/articles/115006348748-Directly-On-Demand-Customer-to-Customer-Support.

Though not paid Republic employees, I as well as my fellow Republic Community Ambassadors and Expert Customers know a few things about Republic Wireless. :wink:

I’m trying to figure out the best way to get the information regarding Level 3 to those handling your ticket, which will take me more than 5 minutes.

1 Like

Hi @lynne,

I believe the necessary information has or shortly will reach the agents handling your ticket. Please watch for their further response on that ticket and :crossed_fingers: the invalid zip code issue will be resolved.

So is it my responsibility to enter this new zip when I try to convert from legacy 4.0 to 5.0? Or will they “reprogram”(not sure of the correct word) my account to reflect my current zip?

Please wait for their reply and further guidance. If there’s still confusion on how to proceed, please post back here.

They provided me with an old address from Toledo. I used that in place of my current when attempting to activate my 5.0 line.
“YOUR number is not eligible for porting’.”

Granted maybe that new address might work if I was leaving RW…not sure.

This error indicates someone has already initiated a pending port on your behalf. As you previously mention attempting to port out of Republic, that someone isn’t necessarily Republic.

If another carrier has initiated a pending port on your behalf, you would need to reach out to them and ask they cancel the pending port.

Once done, you would be able to initiate a new port with Republic to move from 4.0 to 5.0 or with another carrier to move to their service.

Once the currently pending port is cancelled and you are ready to initiate a new port, use the Toledo address and zip code.

1 Like