Porting from RW to new 5.0 plan failed

What phone do you have? moto g stylus 5G

What plan are you on? RW 5.0 from legacy

Does your plan include data, or just talk & text? yes, old plan had some data, new plan unlimited


Issue Description

Started Dec 28, porting two numbers from legacy to 5.0.
First line went through, but took 6 days for the new plan to transfer completely to the new phone. Not a problem since the old phone continued to receive calls and texts.
Second line had a PIN mismatch, since the line had been assigned. I had made sure my PIN was correct, didn’t realize that the assigned number had a unique PIN. Got an email that the port failed, called support to reset the port request. Support said the port was canceled, wait a while the try again. Waited 24 hours, tried the activate again, system says I have an invalid SIM. Have called several times, support says they have a known problem, engineering is working on it. I have no indication when this is going to get worked on. There needs to be a way to get to the engineering person who can work on the problem.

1 Like

Exact same thing happened to me. I had assumed that the account PIN was the one needed. I’m still waiting for a resolution.

The status of the issue can be tracked here: Republic Wireless Status - Temporary paused: Number transfers to our 5.0 plans