Private Number calls

All my incoming calls keep coming in as Private Number…so i don’t know who is calling me. i have opened tickets already but nothing has helped. Did something change with the carrier which i’m assuming is T Mobile now??

Hi @garyd.ygejkg and welcome to the Community!

Nothing that would explain what you describe. If, literally, all your inbound calls show as Private Number, working with a Republic technician via help ticket is the appropriate route. Are any of the referenced tickets still open?

The other possibility if many but not all inbound calls show Private Caller is whomever is calling is blocking their number. Private Caller is what one might see if the party calling is blocking their outbound CallerID. Do you receive any calls that don’t say Private Number? Do you have another phone from which you could call your Republic cell phone? If so, does calling from that phone show as Private Caller?

1 Like

ALL incoming calls show as private number. Nobody is blocking.

Then, I suggest following-up on your ticket(s).

1 Like

Hi @garyd.ygejkg,

The reason @rolandh is suggesting that you follow up on your ticket (and it’s better if there’s only one ticket, we typically merge multiple tickets into one, so that we can follow the conversation without repeating steps and overlapping troubleshooting steps) is that this doesn’t sound like something the Community can help with. We’re not familiar with any type of setting on the phone that would account for this.

I looked into your history with our Help Team and I see several conversations, but in each one, I see that you were given steps and asked to reply if the issue persists.

You have a ticket and a recent chat with our Help Team, and you began the conversation here and another with one of our Experts. The Expert and our Community have advised you to return to your ticket and let the Help Team know that your issue has not yet been resolved.

What is very helpful is if you let the Help Team know exactly what you’ve tried and whether or not you saw any improvement.

For example, I see you’ve been advised of the following steps:

  • Update the Republic Wireless App

  • Make sure caller ID is set to network default.
    And I see that you did reply that you had done both of those steps with no improvement.
    However, I also see that you were advised to try these two steps:

  • How to Clear the Cache of All Installed Apps on the Huawei Ascend 5W

  • How to Clear the Android System Cache on the Huawei Ascend 5W
    But as yet, you have not replied on the ticket to let the team know if that helped. In fact, your ticket has moved to a “solved” status because of the length of time since our team has heard from you. I’m going to move it back into a “pending” state so that you can still reply there.

I also see that in chat, the agent advised you to factory reset the phone. I can understand being hesitant to take that step.

I’ve reviewed your service line and do see that it is subscribed for “caller id” - the feature is enabled with T-Mobile.

Could you please let us know if you have cleared the cache (both set of instructions) as the Help Team advised? I’d also be curious to know how much memory your phone has available.

I’d like to try a couple of test calls to your number, too, once you’ve cleared the cache and let us know about the available memory.

Edited to add: I do see one other question from someone with the same phone you have indicating that all calls are coming is as “private caller” in the last few days. I’ll try to watch to see if we start getting additional reports.

1 Like

Hi @garyd.ygejkg,

One of our technicians was able to replicate the issue you are seeing and has written a Help Article describing how he was able to resolve the issue. Please let me know if this solves it for you as well:

I have the exact same problem with the exact same kind of phone and after jumping through all the hoops and over all the hurdles the various levels of support threw down, I still have the same problem. And, NO, the Help Article did not help either. After all was said and done, all RW could tell me was to do a factory reset on my phone!. It seems every time I come to RW with a problem, I ultimately get the same response. And the change where the incoming calls mostly say Private Number was NOT caused by something I did. It appears that it was caused by something RW did with one of their upgrades. Of course, they will never admit to that. Good luck getting a useful answer for this issue - I never have.

Hi @mythicdragon!

I have a Huawei Ascend 5W, and I can recreate and fix this issue on demand. With VoLTE enabled and the phone on cell, numbers come through as Private Number. However, once VoLTE is turned off, calls come through showing the correct number.

Could you provide me with a screenshot of your Mobile Network settings so I can confirm that they match up to what I have?

I rarely use that functionality and did not quickly find out how on RW. Please advise how to create the shot you want - what buttons?

Hi @mythicdragon,

No buttons required:

I have uninstalled and reinstalled the RW app with all updates, and I can assure you that on that screen, both the VoLTE and the Always send and receive MMS are both OFF. It has been set as such for some time and I restart my phone daily. As for my wife’s phone (also a 5W), all five of the settings on that page, including VoLTE are set to ON and she does not get incoming calls with the Private Number message. -Steve

Hi @mythicdragon!

Thanks for that. Looks good.

When you are receiving the Private Number calls, is it on Cell, Wi-Fi or both (if you know)? I have only been able to reproduce this on cell.

Also, does it happen all the time or is it hit or miss?

Given that I am home 95% of the time for obvious reasons, and I do not receive cell service in my house (we are in a valley and I have to leave my property to find a cell signal), I am virtually always on Republic WiFi Calling. It is somewhat hit and miss with Private Number showing up more often than not, but this NEVER happened prior to about a month ago (which I reported previously with no solution). Since I am working from home it is imperative that I be able to identify incoming calls such that I may discern work from non-work calls. The last two incoming calls came from my wife who is also a RW customer using an Ascend 5W phone. She is not having the same problem as I, and ALL of the settings on her phone from the screen shot I sent you are ON. Thanks.

-Steve

Message an
Expert customer