Problem Changing Voicemail Greeting

I just upgraded my Moto Z3 Play to Android Pie on the GSM Parter (same problem exists on my spouse’s Moto X4 with Pie on the CDMA partner). We are running version 3.25.2.1 of the R.W. App.
I tried to follow the directions here:


I never get the pause button (the square on step 6).
It just asks me if I want to save this message (NO OR YES).
If you select “YES” then the caller hears no message.
If you select “NO” it remains the default message.

Any ideas on what I am doing improperly?
It is no big deal, but if I go with the Default, the R.W. App diagnostics warns me I have not set a greeting.
Thanks!

Can you try uninstalling the Republic App, restart the phone and then reinstall. Does that leave the issue?

I did that last night when I could not make a cell call.
It would not let me uninstall the app, I had to disable it and uninstall updates.
I then re-installed the updates, and I could make cell calls at that point.

Did you restart the phone after uninstalling updates but before reinstalling them?

I probably did not, so I disabled it again, rebooted for sure this time.
I then updated the R.W. app.
I made sure the R.W. app had access to EVERYTHING under permissions too.
Went to do the voicemail greeting change, but I still get the NO YES screen (no Pause).

Would you be willing to post a screenshot? If needed the how to is here:


When I press that RED dot to record, the screen immediately changes to this:
voicemail2

Thank you for posting the screenshots! The commonality between your phone and your wife’s is Android 9 Pie. I have a Pixel 2 XL running Pie and don’t experience the issue.

At this point it’s somewhat educated guess time. I believe the Republic app will run in safe mode on your phones. Would you be willing to try attempting to record a custom message with one of your phones in safe mode?

I just got back home from town, and I saw your reply, sorry it took so long to try this.
The Moto Z3 Play did load the R.W. app in safe mode, but unfortunately did the same thing.
When I press the Red record button it went immediately to the YES/NO screen like above.
I am just going to stick with the Default R.W. greeting for now.
it looks like a conflict between the Moto version of Pie, and R.W. App
Thanks for all the help!

Hi @muerte33,

It does seem that way. Have you considered going old school and recording your custom greetings by dialing in:

1 Like

Your old school method worked like a charm!


My spouse said she will just stick with the default R.W. greeting!

Thanks Rolandh!
I marked your post as the solution, so I guess this one can be closed out.

2 Likes
Message an
Expert customer