Problem with device that provides a WAP for control

I have a Moto G5 Plus. I joined Republic Wireless this summer - My Choice + 1GB.

I have a Behringer XR12 PA Mixer that is controlled via WiFi. It can be set to provide a Wireless Access Point - this is how I use it, since the places we play usually don’t have WiFi, and it would be a hassle to long on to wifi for each venue (I won’t be using my phone during a performance anyway, except to control the XR12).
Last April I was able to use the XAir Android App from Music Group IP Ltd to control the XR12. I tried again today, and while the WiFi connects just fine (but without internet, since the XR12 does not have a WAN connection), the app won’t connect.
I’m using the same phone as before, and the app is the same. I’m wondering if the Republic Wireless software could somehow be interfering. How does Republic Wireless know I’m on WiFi in order to redirect calls, text, and data through WiFi?
Has anyone else had problems after switching to Republic with equipment that provides WiFi but not Internet?

  • I am guessing that you are using the RW phones WiFi Hotspot to provide the WiFi/Internet connection via the cell connection for your XR12?

No, I’m not using the phone for a hot spot. I don’t need phone or internet during a performance. I just need an IP connection from the app on my phone to the wireless access point that is built in to the mixer.

I will check the diagnostics, thanks.

If you are connecting to an Ad Hoc wifi network created by a device(the mixer) the phone will not have an internet connection at all unless that device provides a WAN connection and DNS availability etc. through it…that is correct.

I would think that the RW app/services would detect that the connected wifi network has no Internet access(dns queries to say Google.com would fail etc), and would thus route calls and texts via cell network, if available.
If cell signal is too weak, you would have issue, or if you are in Airplane mode, then the cell radio wold be disabled…and you would not get any calls or texts etc.

If you do not need to use the cell connection, put the phone in to Airplane mode, and manually enable the wifi and connect to the mixer. that might help.

Some ad-hoc devices, i have had issues with, needing to be setup to have a static IP address, as they often do not have a DHCP server and some phones freak out and think the connection is bad. Either, u have to set in the ad-hoc device a static IP, or on the phone(connecting device) to have a static IP and gateway, usually specified in the ad hoc devices manual. I have a cheap no name go pro that u have to do this with.

This is most likely related to an OS update done to your phone in the meantime. It doesn’t have anything to do with the Republic software. More recent versions of Android detect there is no internet connection and therefore decide to pass data over the cellular connection instead. This of course won’t work in your situation or things like using wifi to control a drone.

A quick google will find hundreds of people struggling with this same thing, without much in the way of resolution… One solution that seems to work for a number of folks is turning off cellular data on the device. Without an active cell data connection to fall back to, the phone stays on the wifi even if the wifi doesn’t have an internet connection. You may want to give that a try.

2 Likes

Thanks, I’ll give that a try.

Thanks, I’ll try that.

louisdi and SpeedingCheetah both had the solution. Disabling cellular data worked, and so did enabling airplane mode then enabling wifi (which has the same effect).

Thanks to all who responded!

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer