Problems connecting to network

I have a motoG6 phone and back on the 28th of dec you sent an update out while I was driving home. When I found out I had to reboot my phone twice to get running. Since then It has tried to get to me upgrade Sim cards. Today Jan 5 I have no network connection.

What phone do you have? MotoG6

What plan are you on? 2gb plan talk text

Does your plan include data, or just talk & text? I assume all three.


Issue Description

This morning around 8 a.m. I re booted twice both times no connection to network. I have No bars I am not even sure it works in my truck which has it own wireless connection. Any help would be appreciated
John.

Hi @JohnYeatts,

Presuming this was an Android update, it was sent to your phone by Motorola not Republic. The manufacturer controls operating system updates. All Republic updates on our phones is the Republic Wireless app and, if installed, Republic Anywhere.

That said, I’m sorry to hear of the circumstances. Have you tried powering down your G6, removing and reseating its SIM and, finally powering up the phone again? Does that restore network connectivity?

I just removed the Sim card… put it back in… and still no bar on the phone… What next ??

Hi @JohnYeatts,

For next steps, we need to know the type of SIM in your G6. Here’s how to tell: How to Tell If a Phone Is Active on GSM or CDMA – Republic Help. Please let us know.

Upon further review, you may need this how to: Is My Republic Wireless SIM Card CDMA or GSM? – Republic Help.

My Sim card says GSM It is the same card that Republic sent when I got the phone. So it is 32 MB I think or what eve the Moto took at that time.

I hope this helps
John

It does. Please try the following:

Refresh your phone’s, Republic activation as described here: How to Refresh the Republic Wireless Activation – Republic Help.

With that done:

At Settings -> Data usage; please be certain Cellular data is toggled on.

At Settings -> More -> Cellular networks; please be certain Data roaming is toggled on.

Lastly reset Network Settings. Please know this step will clear out any saved connections for WiFi and Bluetooth. To do so:

At Settings -> More -> Network settings reset; read the warning then tap “Reset Settings.” You will be warned a second time. Tap “Reset Settings” to confirm. The process will usually take 5-10 seconds and the cellular signal bars icon will go away for a moment. Once the cell signal bars icon returns, please restart your phone.

1 Like

Ok, did that… still no bars… Next ?
John

Berfore proceeding, I would like to confirm, this experience started after an Android operating system update. If so, please confirm the software channel on the G6: How to Find the Software Channel on Motorola Phones – Republic Help.

Software Channel is retus. As for the update. I was driving home from Fredricksburg Texas on the 28th. Didn’t look much after I got on the road. So I didn’t notice the update until I got home. The phone gradually been giving me more and more trouble ever since. From not working while trying to get gas a couple of days ago, To today being the worst. FYI. This phone keeps asking me to buy a Republic Sim Card… I hope this helps

John

At this point, I’d say there are three possibilities.

  1. An operating system update hangover
  2. A defective SIM
  3. A defective SIM card reader in the phone

Possible solutions for the first scenario are clearing the cache (if available): How to Clear the Android System Cache on Motorola and Nexus Phones Running Android 8.0 or Below – Republic Help. Or, a factory reset: How to Factory Reset Your Phone.

Scenarios 2 and 3 would be difficult to determine here unless you happen to have a spare SIM laying around.

1 Like

I’ll try this tomorrow…when my heads a bit clear er… Thank you for all your help… I don’t think I have a sim card hanging around that would fit. I guess I should ask what would happen if it is the sim card reader in the phone. ? Do I have to buy a new phone since this one is more than likely out of warranty ?..But one thing at a time.

I’ll keep you updated

John

Hi @JohnYeatts,

Clearing the cache is non-destructive, so there’s no harm trying that at your convenience. It occurs to me before you factory reset, we should at least look at what coverage should be. Would you be willing to share a zip code?

76088

Hi @JohnYeatts,

Hold off on that factory reset. This is Weatherford, TX, correct. I’m looking at the partner carrier’s map and for GSM coverage I see “fair”. Said partner carrier describes that as “Cell reception outdoors and occasionally indoors”.

I can’t explain why this hasn’t been an issue prior to the recent update you reference, however, if it were me, I’d do this: How to Request a 3.0 CDMA SIM Card – Republic Help. I believe doing so will improve your coverage experience dramatically. I’ve looked at the CDMA partner’s coverage as well and unlike GSM its robust.

1 Like

Hi @JohnYeatts,

Before you open that ticket, could you please work through this one other Help Article:

Please note, too that there are additional instructions to click that point to:

1 Like

Hi SouthPaw…… I have done as you asked. Removed the sim card. Re booted. Then lost my wifi connection. It is using wifi radio now. Why I don’t know.

I do appreciate your assistance….I am not sure what the problem is… I just hope updating the sim card helps…and then you can help me transfer from the old to the new sim card… I will be forwarding the information on my phone if I haven’t for the 3.0 sim card.

Thanks again

John

Hi @JohnYeatts,

Please note that I’m replying to you in our Member Community, which is publicly visible. Even though you may be seeing my replies in your E-mail, and sending your answer by E-mail, the conversation is taking place in our Member Community, visible on the internet.

I’ve deleted your reply that contained your address.

I’m not sure from what you wrote about removing the SIM card and rebooting if the phone was able to do any more updates as it needs to do? Could you tell us its current build number?

I’ll look in on you later today to see about getting that alternate SIM card to you.

2 Likes

Just an update for Southpayw and Roland…I was able to find a 14 gb sim card. I installed it in the republic phone and it did stop the constant…you need to buy a republic sim card from popping up. That is the good news. The bad news is there are still no bars…

I am trying…
Thanks again for your help
John

Hi @JohnYeatts,

SIM cards don’t come in GB. MicroSD cards come in GB. SIMs don’t store content, they merely (at least by design) provide access to a cellular network. Without knowing whose SIM you found and installed, it’s impossible to comment on the lack of connectivity (bars).

Anyway, it sounds like you and @southpaw are on your way to resolution. Hang in there, I’m confident things will get sorted.

Message an
Expert customer