Problems solved by buying a new phone; well duh! Moto x 2nd gen difficulty connecting while I'm in the car?


#1

What phone do you have?
Moto X 2nd gen
What plan are you on? ? a cheap one. It always worked before. Now I look like an idiot in a room full of people who can ALL connect on iphones, and also my browser and gps fail when I need them most (out of town!).

Does your plan include data, or just talk & text? includes data. I only pay $15-20 (mostly) a month for all that.


Issue Description

Example: last night I was in Atlanta. On my way there from Chattanooga, TN, NO Problem. As I’m leaving to re do my desired location, no connection. Ridiculous. I was not in the boondocks. I was in downtown Lawrenceville, GA. I went ahead and traveled a few miles, just driving from memory and at some point, maybe 5 minutes later or 5-8 miles later, I got a connection. Then I decided to look up a store to see if there is one on my route, I used Chrome/Google, and there is no connection again! My phone worked great for a year or two. Is this a planned thing that my phone will just be obsolete in 2-3 years? Very irritating. This has been going on for almost a year. I don’t need the latest and best phone, mine has worked fine. PS: I LOVED RW and told people about it, now I’m just embarrassed because I can’t connect when I need to.


#2

When the phone isn’t working where it should, it’s a good idea up update the data profile and prl. Sprint has done a bunch of tower work and network changes over the last couple years, and many times updating these two items will get you back on track:


#3

Yes, I do update/refresh the 3 elements under system or whatever it is. I’m not sure it does anything anymore. I do it a couple times a week actually, thinking it will fix my problem.


#4

Other than making sure data roaming is enabled, I don’t have much more advice for you. It might be time to open a Help Ticket | Republic Wireless.


#5

Thanks. :slight_smile:


#6

Trying to find where “data roaming” is on the settings on my phone. I know I’ve seen it, but can’t find it. That could be my problem.


#7

You can find it in the Republic Wireless app on your phone:

Procedure

  1. Open Republic Wireless app
  2. Tap gear icon in the top right-hand corner of your screen
  3. Tap Cell data settings
  4. Tap the box to the right of Roaming data

#8

Rats, it was on anyway.


#9

I’m not sure the settings in the Republic App are what we’re actually looking for here (that’s the settings as to whether YOU have access to data roaming on the refund plans, it has nothing to do with if the phone itself has data roaming turned on). Please check here:

Settings – More – Mobile Networks – Data Roaming What’s that look like?


#10

When I open that (which I have multiple times lately) in grayed out letters it says “Network Mode Home only” and it will not do anything when I touch it, no options, no typing keyboard. Nothing can be done on this “page”.


#11

Ok, that’s actually the way it should be set. Thanks for checking. I doubted that was it anyway because you would have signal in that case, just not data, which on the Moto X2 isn’t needed for use.


#13

@maryluc.6h9mml,

Are you on a 1.0 plan or the 2.0 Refund plan. If on 1.0 3G or 4G data speed?

May be a good idea to check out the greyed out settings looking at - Data usage- 3 dots - Cellular networks. Preferred network type should be LTE.

My G3 SIM needed to be replaced when my phone wouldn’t receive 4G LTE and 3g was being displayed. i discovered my issue after reading another topic. Problems messaging when roaming

:flight_departure:


#14

Hi @maryluc.6h9mml,

Sorry to read you’ve been having this issue over the last year or so! You must be a very patient person.

Could you please check to make sure none of the apps you’re trying to use are restricted from using data? Look at the “Cell data usage” section of this article:

Sometimes I’ve had trouble when I leave a building and am in my car in the parking lot, getting access to data. If the phone is still connected to the building’s Wi-Fi network, the network may not have enough strength to really do anything out in the parking lot. Turning off Wi-Fi or disconnecting from that Wi-Fi network is usually all I have to do to access cellular data and get my map directions working.


#16

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.