Problems using my Moto E6

I’m a beginner. I have the Moto e6. I really dislike how it is unresponsive when you turn it on or try to access the screen. Sometimes I have to push the on 4 or 5 times. Often it puts itself in airplane mode and I don’t know it has done that and I miss important calls. The photos are terrible also. So, how do you fix any or all of those issues. Thanks

Hi @dianeb,

Thanks for entering our Community Challenge. I’ve moved your post to our problem-solving category, because what you have listed is more of a request for help with some basics about using your phone rather than a how-to about learning to do something specific I’m not moving the post in any sort of punitive way, just to make sure it gets the attention it deserves you get the help you need.

I hope the Community, and in particular, some other Moto E6 users will be able to chime in with some suggestions. It’s not a phone I have available, so my ability to problem solve for these specific issues is limited.

First, I’m wondering if you have a case on the phone? Sometimes the on/off button on a case can interfere with the functionality of the actual button.
When you talk about it being difficult to turn on, do you mean really turn it on - from it being completely powered off, or do you mean lighting up the screen when it is asleep?
The Moto E6 is a lower priced phone, so it doesn’t have the snappiest processor. It may take it a little time to respond, and so you may have to train yourself to allow for that.
To turn it on when it’s truly off - powered down completely - you’ll want to press the power button and hold it until it responds. That way it should take only one press to get it to turn on.
To wake it when it’s asleep, press it once, firmly for about half a second (which is longer than it sounds) and then let go of the button and make yourself wait. I’m imagining that if you’re pressing, seeing no response, pressing, seeing no response, pressing… that what you’re actually doing is waking it, and before the screen can light up, you’re pressing the button again which tells the phone to go back to sleep. So you’re kind of in a cycle of having to try multiple times.

This is very unusual. Let’s make absolutely sure you’re not accidentally bumping the button that turns on Airplane mode.

  1. Touch the top of your screen and drag your finger downward, twice to open the “quick settings” menu.
  2. Tap the pencil icon at the bottom left of that pull-down screen.
  3. Find the Airplane Mode icon in the list and touch and hold it, then drag it to the “drag here remove” section.

If what I’ve written doesn’t solve either of the issues you’re experiencing, we may want to take a look at the apps you have on the phone to see if there may be something that’s bogging down the processor (for the slow-to-respond issue), or somehow enabling airplane mode.


It’s ok. the phone is in sleep mode and frequently is very unresponsive. I’m not accidentally hitting the airplane mode. Yes it is an inexpensive phone and it is much worse than the other inexpensive phones I’ve had. Mostly motorola.

Do you mind moving the airplane mode toggle just to be sure?

Okay, then we may need to start looking at what apps on your phone might be bogging it down. When was the last time you completely powered it down?

You didn’t mention if the phone has a case?

The airplane mode is not at the top of the screen to pull down. Yes I have a sleeve but it is not in the way of the buttons. I do have apps. I power down the phone at least once a day because my email freezes.

Hi @dianeb,

You might give safe mode a shot and see if the phone still acts sluggishly:

This can help tell us if any apps might be at fault for some of your issues. :thinking:

Thanks, Ill give that a shot!

I found the same issue with an unresponsive power button. I turned off the shortcut for the power button to bring up Google Assistant and it completely fixed the problem with the power button. Here are the instructions:
Go to Settings > System > Gestures > Double press key > You will see an option to set it to none, launch camera or launch assistance. Set it to none.

1 Like

Thank you.

Hi @dianeb,

Did any of the suggestions offered help at all?

Turning off the shortcut to the power button helped somewhat. I would persuade people not to get this phone though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer