Problems w anywhere and voicemail today - both fixed!

What phone do you have? Moto G7

What plan are you on? My Choice Talk & Text

Does your plan include data, or just talk & text? all


Issue Description

First of all, I’ve been with Republic wireless for years and have had this phone over a year. I do not need a basic ‘how to set up’.

Today I am having problems with both voicemail and messaging.

Voicemail - a call came in, rang once, and when I tried to pick up, it seemed to disconnect. An hour later, I finally had a voicemail notification. However, my ‘visual voicemail’ is gone. I’ve been using THAT for probably over a year already, but today its gone.

Text - shortly after I noticed the missing voicemails, my Republic Anywhere app on my PC asked me to sign in and install, including installing on my phone. When I got it to open, it had lost contact information and only had 5 conversations showing, most of which were weeks old.

My son also had a call (from his doctor’s office) go straight to voicemail this morning.

Is there something going on? Is anyone else having issues?

I just called my Extend Home from my Cell. The Extend Home rang 1 time and then my call went to voice mail but in the mail checking mode. I successfully checked my voice mail but the call process was definitely flawed.

I’ve experienced what you describe with Anywhere on my PC but not for a few months. It has been working for me just fine today. RW no longer supports this wonderful product.

i had a problem w anywhere a few weeks ago, maybe a month or two, but it turned out there was an outage and it was corrected

Ok, funniest thing - when my son texted me, it only showed up on my phone, but when I typed in his number on my PC anywhere, I was able to send and receive messages . . .but it seems that my messages from my PC showed up on his phone as having come from his brother . . .

Ok - i figured out the Anywhere problem! I had updated my account so that my youngest’s phone showed up under his name in my account - but i’d updated the wrong number. As soon as I corrected the assignments, my texting was all fixed.

But the voicemail is still not working

Ok, support sent clearer instructions on how to uninstall and reinstall ‘phone’ . . . that worked! Not PERFECTLY clear instructions, but i figured it out

1 Like

Hi @caraz,
If you could provide details you feel were lacking or unclear, one of us (Ambassadors) can submit a change request into the Help Doc folks at Republic.

Procedure

  1. Open the Google Play store
  2. Tap Search Bar
  3. Search Phone

here you have to select ‘Phone by Google’, which says ‘installed’ under it

  1. Tap Uninstall
    ** pretty sure you had to tap ‘uninstall’ twice **
  2. Tap OK
  3. Tap Update
2 Likes

I just walked through this on my Moto Z4 and Samsung Galaxy20 and yes, I did have to first Tap ‘Uninstall’ and then confirmed when the window asking me to confirm, this is standard across any app that I request to ‘Uninstall’ … lets see if someone else chimes in, as I think further explanation may not be needed?

1 Like

Hi @caraz,

I’ve inserted a new step 4 into the Help Article.

  1. If more than one “Phone” app is listed, tap Phone by Google

Thank you for suggesting the improvement.

4 Likes
Message an
Expert customer