Question regarding 3.0 cell switching to roaming - then not switching back

Ok…so I recognize the service isn’t that great in my area, but I have an issue where the phone switches to roaming in certain parts of my office buildings or while driving locally. A perfect example is, while sitting at my desk, I have LTE, but if I go down the hall to a conference room, it switches to roaming. Then, I’ll go back to my desk and the phone won’t switch right back LTE…I have actually had to turn off the cell data and turn it back on to get it to switch back. I have also had this happen driving. I’ll go through a weak cell area, it’ll switch to roaming and then it won’t come right back when the service is solid again. The service map shows I should have exceptional service where this is happening as well, which is frustrating.

Anyone having this happen? How do I avoid this?

Thanks,

Frank

Anyone? Bueller…Bueller…Bueller…

This has been extremely irritating…for example, if I go to the restroom in my building, which is in the center of the building, it’ll switch to “R” - but 100’ from that restroom I have LTE. I can’t get it to switch back to LTE unless I turn off the cell and turn it back on. What gives…

How do I avoid this?

Technically only points 1 and 3 are avoidance methods. Number 2 describes active measures once the issue recurs.

  1. Use Wi-Fi. The higher cell network frequencies don’t penetrate buildings well. Service maps don’t show that.
  2. Besides turning off cell data you can accomplish the same thing, which amounts to locking on to a different tower, by rebooting (not what you are looking for, I’m sure), turning your cell radio off and then back on again, essentially the same as switching to Airplane mode and then toggling back again – if you must have cell data. There used to be a Play Store app that reset the cell radio, don’t know the current status of it but it was faster than rebooting and easier than toggling the radio(s) off and on.
  3. Lock your phone inside your desk and catch up on anything you need to respond to or want to look at when you get back.

Even the best 4G LTE coverage such as on RW’s GSM carrier map will say “in most homes and big building” so the center of a building may not provide good reception.

As to why it doesn’t switch back? You may have LTE at your desk but not strong enough to enable a switch back from roaming. How long of a time do you give for the switch back? Have you tried changing Settings, Wireless & networks, More, Cellular networks? Possibly a slight detour around the building on the way back to your desk would help.

  1. I don’t have WiFi in my building - well we have it, just not open to off network devices.

  2. Not exactly what I am looking for…

  3. This doesn’t only happen in my office, that was just an example. It happens when driving and I lose a tower, I can be driving and be stuck on “R”. I never had this issue on the “CDMA” network with my Moto X.

I am not sure which settings I would need to change…I think it is set the way it should be, unless I should turn off “connect to data services when roaming” - is this what is causing this?

Only a suggestion to try a different setting and change back if it doesn’t help. I’m a member here and not an expert, just offering an easy thing to try. Toggling settings on/off would be easier than powering on/off if it helped.

I am really shocked that others aren’t having this issue…

Message an
Expert customer