Random signal and WiFi dropouts despite being in coverage map

I’ve been having some serious issues lately where, despite me being in a Strong 4G LTE network per the coverage map (zip code is 46818). I will lose all signal, and it randomly won’t reconnect even if I restart as well as power the phone off, waiting about a minute, then turning it back on again.

When it comes to WiFi, it only happens on any network outside of my house (grocery stores, workplace, etc.). When it comes to the strong LTE network, it randomly just drops out and won’t reconnect (I get the error that I can’t place calls due to no signal), even if I restart the phone or power the phone off, wait a minute, then power the phone back on.

I’ve already cleared the phone cache, performed a factory reset, forgotten WiFi networks, and tried switching Preferred network type (even though I know that probably wouldn’t do much). The one thing that “kind of” fixed the issue was switching to Turn off the WiFi, turn on Airplane mode, turning the WiFi back on, then turn off Airplane mode, but even then, it only connects for a few seconds. I even took my phone case off to see if that was affecting anything

If it helps, it’s been occurring a lot more frequently lately.

Moto G6 Play

My Choice +1GB

Includes Data


A much-belated response, my bad :blush:

  • Could you check how you have a couple of settings on your phone set?

    • Republic Wireless App / :settingsicon: Settings / Advanced Settings
  • The settings of these two might trigger some additional discussion on the problem you are experiencing

Hello! The only thing disabled in the Advanced Settings is Allow Manual Handover. I can enable that and see how that goes. I’ll report back.

The Manual Handover setting is not a concern. Sorry, my request wasn’t clear.

  • Let me restate
    • ‘Enable handover on networks’, does this show all the network SSID’s you have authenticated in the past, or have you limited this to the few that are important to you and often visited? (like Work, Home, Lowes)
    • ‘Handover to WiFi when appropriate’ … this is a go/no go, so if enabled it will handover to WiFi when you return to an area and the WiFi signal is stable enough to support the phone call that’s in progress

Thanks for the clarity! It currently shows all the networks I have authenticated in the past (all of which have the green checkbox).

At this point, I would uncheck all but the major couple of SSID’s and see if this help eliminate the unwanted connections.

1 Like
Message an
Expert customer