RCS Chat Feature no longer working

Phone: Moto Z3 Play
Republic plan: Mobile Data plan
App: Messages 5.7.097
Carrier services 37.0.301439906

I’ve been using RCS Chat successfully through Messages since November, but starting yesterday I now get a new message note when viewing the Chat Features in Settings. “Chat features unavailable for this device. Your carrier does not currently support this.” I’m not seeing any recent updates to either Carrier Services or Messages apps. I’ve tried clearing cache and reinstalling.

Did something change with Republic to now not allow this feature?

Republic was uninvolved in enabling it, and uninvolved in any issues you may be having. The usual recommendations that I’ve seen is to begin by clearing the cache/data for carrier services.

There is a pretty active community on reddit: https://reddit.com/r/universalprofile

Hi @peterg.vog5dh and welcome back to the Member Community. Others have reported varying degrees of success using RCS chat. Here’s what RW says about RCS chat at this time –

I’ve never had any success when I tried it. Don’t know of any recent RW changes either.

1 Like
Message an
Expert customer