Re-activated previously de-activated Republic Wireless phone, Invalid SIM issues

What phone do you have? Moto G5s Plus

What plan are you on? My Choice Talk & Text

Does your plan include data, or just talk & text? My Choice Talk & Text only


Issue Description

I have an Moto G5s plus that was purchased new with Republic several years ago, upgraded to a newer phone a while ago and put the Moto in a drawer. Recently activated Republic service on it for my daughter’s first phone and she is consistently having invalid sim card issues and message not sent issues. Restart the phone and everything works fine for a while, then will shut off again.

No error messages or prompts from Republic app (which is updated) telling me what is wrong. Keep getting notifications that activation is underway or restart to activate, but same error loops over and over.

Did some research and it looks like I might need a new sim card? No notice of that during activation with Republic, so that might be a process improvement.

Can I also have the service time frame adjusted from when I activated it several days ago until a new sim arrives? I haven’t ordered one yet as I don’t know if that is the issue and don’t want to waste $10 on one after shipping.

Thank you for any help you can provide.

  • Brad

To start, I would suggest you run the Diagnostics that are an integral part of the Republic Wireless App. This should the phone through 50+ test and provide you a graphic report showing number of warnings or failures if any are detected.

  • Republic Wireless App / (?) tab / Run diagnostics test

Hi @bradb,

The experience is often though not always the result of a “loose” SIM. Before contemplating SIM replacement or even running diagnostics, I would try removing, then reseating the SIM. Best practice would be to power down the phone prior to doing so.

1 Like

Hi @bradb - and here’s an RW how-to for How to Remove and Reinstall the SIM Card in a Moto G5S Plus if you are not familiar with the process.

1 Like

Hi @bradb,

Please don’t order a SIM card if the advice given previously in this topic does not resolve the issues you’re seeing. Our Help Team would be glad to provide one if the issue persists after other troubleshooting steps have been taken.

We can’t adjust your billing cycle date, but our help team would consider a service credit if the phone has been inoperable for an extended period of time.

1 Like

I shut the phone off and removed/reinstalled the sim card. No change.

Thank you for the link freddyp.

Hi southpaw, I appreciate the info. Please let me know if the diagnostic image I pasted gives you any next steps for me to try. My account records should show the purchase of the moto g some time ago, so that should help to verify it is indeed a republic sim card. I could always snap a pic of it as well if needed.

No, there’s no amount of “evidence” that’s going to make something work if it’s not working. I can see the SIM card information in our account management tools.

Someone is looking into your issue, I’ll let you know if we’re going to need to help you in a Help Ticket instead.

Hi @bradb,

The technician who looked over the SIM card’s provisioning could not find an issue. I’ve opened a ticket on your behalf. You can work with us through the help center by logging in here: https://help.republicwireless.com/hc/en-us/requests/1963734

To augment the instructions that @freddyp previously provided, I would suggest that you clean the SIM card contacts, as often any electronic contacts not actively in use can become corroded ( and preventing good contact)
Here is an excellent set of instructions from WikiHow

For posterity’s sake:

Republic sent a new sim card at no cost to myself (Thank you @southpaw and Republic) which I have just installed in my daughter’s phone. Activation of the new sim card is underway. I will update with any issues or if, after several days of use, it seems to fix the problem.

After installing the new sim card and using republic to switch my Daughter’s number to the sim card, ‘sprintDM’ tries to configure the celluar network. The republic diagnostic test still fails ‘cell network operator’ category, stating ‘the cell network is not one of republic’s partners. Please check that you have a republic SIM inserted.’

Attempting to place a call on wifi after the sprintdm message went away generated a republic message ‘Cell configuration required: An update is required in order for cell service to work properly. You may be asked to tap OK on another prompt to begin this update, otherwise it will begin automatically. If your phone doesn’t restart itself within 30 seconds, please restart it manually’.

Nothing happened and opening the play store and searching for republic just shows open or uninstall, leading me to believe it has the most current version. SprintDM is now on retry 3 of 5 to configure the cell network. Force restarting the phone.

After restarting the phone, SprintDM tries to configure the network again. I don’t have more time to troubleshoot at this point but it appears I may still have an issue. Anything that can be looked into from republic’s end without a ticket or should I open a new one?

Thank you as always for all your help.

You can safely ignore this diagnostic. The diagnostic test is misreading the network operator code.

I believe what you’re seeing will clear up with a few reboots and a chance for the phone to get a good handshake with Sprint’s network.

1 Like

Thank you! After having returned home, my daughter says the phone hasn’t been giving her any issues, so it sounds like you were right! I appreciate your help!

1 Like

Sorry to be a bother, but my daughter’s phone just got another ‘cell configuration required’ message when she tried to place a call over wifi. Running the diagnostic came up with a ‘free storage’ error (most likely due to her taking pictures and video of everything), the ‘cell network operator’ issue I was advised might go away, and the voicemail greeting notification (most likely neither here nor there, but included for the sake of completeness).

When I go to the full logs the line ‘has sim card’ pass is 1 and the line ‘has republic sim card’ pass is true. It also seems to show as ready with carrier privileges.

Thanks again for any help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer