RE-Activation Issues if a former customer trying to come back

What phone do you have? Moto E 1st Gen

What plan are you on? Legacy WIFI only

Does your plan include data, or just talk & text? No


Issue Description

Hopefully this info helps someone experiencing the same problem…GL!

  • I was a former customer back in 2015 and would like to switch back…I still have my old moto e and was wondering how to go about it…I would like the same number that I had with ya’ll the first time and which is currently tied to ting mobile via freedompop…not quite sure where to start…any advice would be greatly appreciated thanks in advance…

Johnny_5 answered…

johnny_5

17837 Answers • 99% Helpful
Hi Will,

You will first need to reactivate the phone as a new line of service with a new (temporary) number.

To do that, turn on the phone and connect it to WiFi.
Open the Republic Wireless app.
You will activate the phone as a new line of service.

Once that completes, you will be able to transfer the number. Here is a link to the guide for that:

If you have any further questions, please ask.

Regards,
johnny_5

Willh10

Thanks for the quick response unfortunately the republic wireless app doesn’t show up in my Google play store…so I work around that by Google searching it and then clicking on it…then it seems to work but then after I pick a plan and fill out all the CC info and click next I get this continuous spinning circle and nothing happens after that…I even tried a factory reset and the same thing happened…I remember reading somewhere that you need at least Android 6.0 or higher and sadly this Moto E has only 4.4.4. So is that the issue or is it something else? It’s a republic wireless phone so you’d think there would be a way to update it so you could always use it and not have to keep upgrading your phone and buy a newer phone every few years etc etc… surely something can be done please let me know and again thanks in advance I appreciate it very much.

CoreyK

124966 Answers • 99% Helpful

Hello Will,

My name is Corey. I am a Republic Wireless Customer Expert. I would be glad to try to assist you or point you in the right direction. I recommend that you update your Republic Wireless app by following the directions below.

  1. Open the Play Store app
  2. Click the three lines on the upper left
  3. Click on My Apps and Games
  4. Scroll down until you find the Republic Wireless app and click it
  5. Click on update.
  6. Reboot the phone

Let me know how it goes.

Corey K
Republic Wireless Community expert and customer

CoreyK

124966 Answers • 99% Helpful

Did that allow you to activate the phone? After activation is when you would start the transfer.

Willh10

Actually it was a little more complicated than that but in the end I was able to figure it all out…in case someone else comes on here with the same issue here are the steps I had to take to get my phone to work and activate. First off after updating the Republic Wireless App I was still having the same issue of the dreaded continuous spinning circle after updating my Credit Card info. Since I kept getting stuck in this particular spot on a hunch I went ahead and clicked on the “Next” button WITHOUT changing/updating my Credit Card info and magically it went to the next and final screen instantly. I got a order number and everything. Of course my card was declined as that was my old info from 4 years ago. So after doing some researching I was able to determine that I had to sign in on a computer and change my payment info there and not in the App and then go back to the App and try the Activation again and voila it worked perfectly! Apparently the App gets stuck when you try to change your Credit Card Number and Billing Address for some unknown reason. Also lastly I did even try creating an account from scratch with a different email address than the one on file from being a former customer years ago and I would still get the spinning circle at the same point after this time “entering” and not “changing” my Credit Card info so maybe it was just a glitch or something I’m not quite sure. All in all if anyone else has a problem after entering their Credit Card info they should just go online on a computer and enter/change it there so it is correct and THEN go to your phone and start the Activation process and then all you have to do is just click activate and it will go through no problem. I imagine I will not be the only one coming back from Freedompop and now Ting after the buyout from Sprint etc etc and so others who have been gone for awhile might experience this same glitch. Hope this long winded post helps I just figured the more specific info I included the better haha. Cheers and thanks again!

  • CoreyK

CoreyK

124966 Answers • 99% Helpful

You’re welcome.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer