Recent porting out reports anyone?

With all the festivities going on with the new rollouts, I wonder if anyone has any success stories since the new plans dropped on the timeliness of the port out process?

My request has been initiated by the new carrier (ID# and PIN’s processed successfully) , and I understand the wireline-> wireless configuration. I believe the process to be automated, but it’s clear some processes aren’t as robust as they once might have been, so I’m curious.

Thanks and Merry Christmas

1 Like

I’m in the process of trying to port out to a new carrier @syfr. Although I will be back to republic, the new plans and the fact that my current phone would not be functional after June (CDMA) and I would have to get a new phone anyway led me to going to a new provider who also provided a “free” phone (no contract but is paid off over 24 months and I tripled check to make sure it was an eligible BYOP with republic). I started the process Dec 20 just after I received the new phone. It still hadn’t activated as of this morning, so I contacted the new provider. Their porting people said that it was supposed to activate on the 22 (2 days ago) and they didn’t know why it hadn’t happened yet. They resent or did something and said that it would be activated after 10 AM and gave me instructions for the phone to cause the activation to go through. He said if it didn’t happen by then to wait an hour. Well, it’s 3 1/2 hours later and I still can’t get it to activate. I don’t know if the problem is from their end or republic’s end. He said the wait was for the current provider (republic) to port the number. I know of no way to check to see where the problem is - if republic hasn’t ported the number or if the new provider is the problem. I don’t wait well…

Some clarity here would be helpful. If there is a porting error, the original request needs to be canceled and a new request sent. You might ask them to try that, but first, confirm that you are giving the correct account number (your 10-digit phone number) and current account PIN.

1 Like

You’re correct @southpaw… I was extremely vague there! I’m attaching the screen shots pretaining to what they told me.



They said that my account# and pin were correct. It looks like maybe they didn’t cancel first, but I can’t really tell from what was said. I SO will miss your customer service… thanks.

Ports don’t fail for unknown reasons. If the port genuinely failed, whomever the provider you’re porting to uses as their carrier knows the reason.

The other possibility is they’re not allowing enough time for the port due to Republic’s VoIP numbers being classified as landlines for porting purposes. You might want to ask for a porting specialist.

1 Like

Thanks @rolandh. IF they didn’t cancel and just resubmitted, that would be a failure, correct? If that is the case, do I need to change my pin with you before they resubmit? (I thought I might have read that someplace but I’ve been reading SO many things all over the place that I’m totally confused now…) As I said, the original port started on Monday, Dec 20.

It depends on why the port failed. It might be for an incorrect PIN or it might be for something else. Pointing you in the right direction requires we know the reason the port failed. The answer you received about it failing for unknown reasons is a lousy one. There’s always a reason, if the port did indeed fail.

Did you receive an email from Republic indicating someone (you) tried to port the number using an incorrect PIN?

No. I’m currently in chat with my new provider… they just connected me with their dedicated team. I’m going to follow through with @southpaw’s and your advice

As long as you’re chatting with them, I suggest letting them know the number being ported is wireline (landline). This may just be a matter of them expecting the port to complete in minutes to hours and presuming the port failed when that doesn’t happen.

Wireline to wireless ports tend to take days not the minutes to hours a wireless to wireless port takes. Most front-line support at other providers have little to no experience with wireline ports.

1 Like

@southpaw and @rolandh - thank you both for your help. As an update, I passed everything along to the new provider that you suggested. They are cancelling the port request (didn’t say whether or not it was cancelled this morning but they cancelled it now) and I have to get in touch with them after 24 hours to put in a new port request.
I truly treasure the support her at republic… you all ARE the best!

Was there not some recent traffic indicating outbound ports to certain carriers taking a very short time? I ask as you say “takes days” not “could take days”.

It all depends upon the carrier (note the carrier is not necessarily the same as the provider) to whom one is porting. Generally, ports involving wireline numbers (Republic numbers are wireline) take days as opposed to minutes to hours.

Of the three national wireless carriers, T-Mobile is, in my experience, the most efficient when porting wireline numbers. If porting to T-Mobile or a provider using T-Mobile’s network, you have a shot but no guarantee of getting it done quickly (less than 24 hours). If porting to AT&T, Verizon or a provider using one of their networks, it will be days (typically 3 business days).

Don’t be fooled if outbound calling works immediately. Until inbound calls are ringing the phone at the new provider, the port is not complete.

3 Likes

Just an FYI… it seems that if you’re trying to export to xfinity mobile, it may take forever! Sigh…

2 Likes

Thanks Roland, that’s what I believed. The phones work as soon as the ID and PIN is verified but they’re using a temporary number. It solves the short term problem (and it’s a slick way to bridge the process) while the transfer of the actual number takes place,

Xfinity Mobile typically takes up to 14 days to port wireline numbers, which is mind boggling because they have their own wireline service (Xfinity Voice). There are reasons, Comcast Xfinity is the only two-time winner of the Golden Poo (no longer awarded) for being the worst company in America with which to do business.

If it’s any consolation, your Republic service continues to work until Xfinity Mobile gets around to it.

2 Likes

Thanks @roland! All because I wanted a free phone. If my Moto X4 could have worked on T-Mobile GSM (GSM T-Mobile is horrible here which is why I have a CDMA SIM) or on a new 5.0 plan, I would have stayed in a heartbeat. Since we have such good luck with Xfinity Internet, I didn’t do my due diligence. I was lured by the siren call of no contract and “free” phone. Lesson learned. I really will miss all of you - and I will lurk in the community.

2 Likes

I can answer my own question now. It took about 20 hours for the complete process.
During the whole time I had a working phone, just under a “loaner” phone number.

I hope you all have a very Merry Christmas!

2 Likes

Thought I would follow up with you on my Christmas miracle @rolandh! :christmas_tree: :santa:After having xfinity cancel my port request yesterday and being told I couldn’t have them make a new one until after 2:30 today (thus the new phone not activating either), I went into my Xfinity account online about an hour ago and no longer saw that it was in the process of activating. I powered up the new phone - and it was activated and working!! I just now received emails that my account and line here have been cancelled…
Thank you again for your help and insight… and to @southpaw for the same always. May you have all the best this Christmas Season and for the coming Happy New Year!

3 Likes

I ported out just a few days ago. At first, it said my PIN was incorrect, but I had spent a long time making sure I knew my PIN from Republic. I called the tech support at my new carrier and the very nice person there said he called Republic to see what was going on and within minutes, my number was ported to my new phone and carrier. I was surprised it did not take several hours for it to port over, but it didn’t. I am not that good at tech stuff, so all in all, it worked out well.

3 Likes

I will be porting 1 line out of Republic later this week. Has anybody else done this since the change to 5.0 and did it work ?