REG09 - Missing 911 address

What phone do you have? Pixel3axl

What plan are you on? full 2gig data talk text

Does your plan include data, or just talk & text? data


Issue Description

Issue registering WiFi calling with your carrier REG09 - Missing 911 address

You may want to open a help ticket. I believe that message is associated with T-Mobile Wi-Fi calling.

Hi @danielc.rlxbj3,

Did you move an active Republic SIM from a previous phone to the Pixel 3a XL? If yes, did you also download and open the Republic app to the Pixel? Doing so would be necessary for Republic service to work properly on the Pixel.

No I got a new sim from RW. I can still make calls WiFi. A confusing alert?

This is because the phone is attempting to activate the Android based wifi calling, which isn’t what Republic uses. Please go to Settings – Network & internet – Mobile network – Advanced – Wifi calling and toggle off wifi calling there. It won’t impact your ability to make wifi calls but will stop the error.

1 Like

Hi… I have the same problem with my Pixel 3A. I did transfer a sim card from my previous phone. I can’t follow the advice above, the settings app keeps closing. I also have Pixel 3xl, that phone did the same thing, I fixed it but don’t remember how! Also I have Android Q, that might be the problem…

Hi @markp.u0rqvo and welcome to the Community!

I’m afraid you’ll need to start there. Republic does not support pre-release Android versions.

Ok thanks! I guess I’ll deal with the error message!
My 3a is a backup phone, no big deal.
Thanks again

Have you tried the solution I posted above?

Hi! Yes I did. After "settings-network and internet- when I click on “mobile network” the phone app just closes.
I got a “Q” over the air update and the error message seems to have gone away.
Thanks for helping! :slight_smile:

OK… The joy of beta software (and the reason companies like Republic don’t support it)!

I know there’s problems with these beta trials, I just can’t help myself!
That’s why I kept my main phone (Pixel 3XL) on Pie.
The “dark mode” in Q is fantastic, worth the troubles quite honestly, imho,

Same issue here. Transferred my SIM from my Nexus 5x and now I get this error whenever I connect to WiFi. I tried to disable WiFi calling as mentioned above but the setting doesn’t appear anywhere in the settings app! Tapping the notification takes me to blank screen. Any thoughts? Android Q is not involved btw.

This is on the Pixel 3/3XL?

It’s the pixel 3a, non-xl

Hmm. Can you open the Republic App, click the gear at the top and then “About”, what does it say there under “SIM Type”?

It says the type is gsm

Thanks for verifying that. Let’s double check the steps here.

  1. In the dialer:

  2. Then:

  3. Then:
    3

  4. Then:
    4

  5. Then:
    5

  6. Which should end up looking like this:


Thanks for the wdalkthrough but my calls screen oesnt have a WiFi calling option. Curiouser and curiouser…

Message an
Expert customer