Republic activation problems

I had a problem with my last sim card of some sort that prevented me from completing my activation for my new samsung J6 phone. So they sent me a new sim card and it says online on my republic account that my account was activated and I recieved an e-mail saying that it was activated 2 days ago but my samsung still says not activated on republic and when I log in to wifi and click republic it still says activation is underway on a green screen and you should receive an e-mail when it’s finished but I recieved the activation e-mail over 2 days ago. What could be the problem?

Hi @josephb.lh0xty ,

You are very patient to have been waiting two days since receiving that E-mail. Have you tried rebooting the phone? Is the phone connected to a Wi-Fi network?

Yes. I have tried rebooting it. Yes it’s connected to optimum wifi.

If it’s connected to Wi-Fi, please try these steps:

  1. Launch the phone dialer, as if you were going to make a call, and tap the icon to bring up the numeric keypad (0-9, # and * only)

  2. Dial * # * # 8647 # * # * (without the spaces, they are just there to avoid creating hashtags).

  3. If the sequence doesn’t automatically clear, tap the send button.

Please let me know if that makes a difference.

Yes. It seems to have worked. I’m able to make calls now finally. Thanks I appreciate it. I’ve been waiting for a long time now between the sim card issue and the activation.

I’m so glad to hear that solved it! I’m going to follow up in your ticket. Thank you for your patience, it has indeed been a long wait.

Message an
Expert customer