Republic "anywhere app" is terrible with iphones


#1

If I use the desktop “republic anywhere” software on my desktop computer, and try to send a long message a person that uses an iphone, the messages ALWAYS seem to come out a jumbled mess!

I don’t think republic wireless actually develops the app, but it is nearly unusable if I want to communicate with a person that uses an iphone


#2

I just did a quick test as follows
On Windows 10 PC
Copied your update above and pasted it to Anywhere Ver 1.5.8

  • Results on iPhone 7 (with Anywhere Installed but not active), I received a 100% accurate copy on the native iMessages
  • Results on iPhone 7 (with Anywhere logged in and active), … results were still the same

Have you checked your versions, which level/type of OS etc?


#3

I think either I misunderstand your test or you misunderstood what I was saying.

I have it installed on a windows 10 pc.
The other person does not have anywhere installed, is not a republic wireless user and is using imessage
I send a few paragraphs of a message (try 500 words or more)
They get an out-of-order mis-mash of garbled nonsense (since it never gets sent in the order that I type)


#4

I sent to a non RW iPhone, (both with and without Anywhere) however the difference appears to be the size of the message your trying to send.
I retested to the max that it appears the app allows image
Used a http://www.dummytextgenerator.com/#jump as I’m a crummy typist :smile:
Still 100% ok

Realizing that Anywhere is a SMS messaging system I am uncertain what the you might expect, as your ISP and your iPhones user is probably different than min.

  • Bottom line, I can’t help, but it works ok for me. Hopefully someone with a bit more knowledge on the subject than I have can offer you some guidance

#5

SMS is not meant for long messages [that’s what email is for], SMS is 160 characters long [140 if Unicode is used] anything over that and it will be broken up into multiple SMS [and the receiving end may recombine the message], there is always a risk that they may be out of order, is may be higher with an IP base system like anywhere


#6

Hi @ee.2hvpvm,

Are your results different if you send the Text using Anywhere from a phone or tablet? (Trying to determine whether the issue is limited to the PC app.)

We do.

We’d love to know if others can reproduce this issue. Thanks, @jben, for trying!

I don’t know if this is even an option on iPhone, but on Android phone there is an option to either have the time set automatically (from a cell tower) or manually. Most of the time when we see jumbled messages on RW phones, the issue is that the user has manually set the time. Do you have any idea whether your iPhone recipient has manually set the time on the iPhone?


#7

then they should put a character limit on it. Seems kind of dumb if there is a 160 character limit, but it lets you send up to 2000 i think.


#8

I’m not sure about the time setting, I’ll have to ask the person and find out.


#9

This is an industry standard, [republic did not even exist when it was develop in the 90’s]


#10

It is: https://support.apple.com/en-us/HT203483.

@drm186 is quite possibly on to something. This may very well be an SMS handling issue (that may or may not be carrier specific) rather than an Anywhere issue. For what it’s worth, the iPhone user you’re messaging with is not using iMessage. iMessage is an Apple service that only works on Apple devices. When messaging with an Android (or other device); though your iPhone friend is using the iOS Messages app, it’s using SMS/MMS. More on that from Apple here: https://support.apple.com/en-us/HT207006.

SMS literally stands for Short Message Service. As originally developed, SMS isn’t intended for long messages. Various attempts to workaround that (most notably use of MMS for longer messages) have been made with varying degrees of success. For others who might be willing to attempt recreating your experience, it would indeed be helpful to know your iPhone correspondents service provider.

Some additional settings your iPhone correspondent might want to check. At Settings -> Messages under the SMS/MMS heading; are both MMS Messaging and Group Messaging enabled?


#11

Hi @ee.2hvpvm,

Some further investigation that may be of interest. I’ve sent three 2000 character messages from the Republic Anywhere desktop app on a Mac to household iPhones. One is on AT&T, the other on T-Mobile. The T-Mobile iPhone received all three messages as single long messages. The AT&T iPhone has yet to receive anything.


#12

The iPhone that I tested with is on Verizon


#13

Here is a screenshot of the test text that I sent VS what they receive Every time I send a message like that it comes out garbled and unreadable to them. (The person is using Sprint)


#14

Hi @ee.2hvpvm,

I assure you no one doubted you. We try to reproduce an issue in order to better understand the issue itself and how widespread it is. Not to discredit you.

When you send a long text message, by the nature of SMS, it is broken into multiple, individual SMS messages. Because you are sending all as one long message, all these individual messages have the same timestamp. Since the receiving iPhone can apparently handle only messages up to the length limit @drm186 cited, and they all have the same timestamp, they appear on the phone out of order.

Edited to add:
I asked earlier whether you get the same result when you text from the phone. Could you let me know the answer?

Once I have that answer, I will show our app developers what you are experiencing and ask if there is anything they can add to the metadata that might help the receiving phone better order the messages.


#15

@ee.2hvpvm, thank you for letting us know the involved carrier is Sprint. No one is denying there’s a problem, we’re simply trying to establish where the problem lies. So far, it appears the tally is with Verizon and T-Mobile the message is received without issue. Sprint receives the message but breaks it up into multiple shorter messages and reconstructs them out of order. Hopefully, Republic’s developers might work some magic with that. On the other hand, the multiple messages I sent to an AT&T iPhone have yet to arrive at all, which suggests AT&T may be refusing the message due to its length.


#16

You may want to check your iPhone users code level (all may testing was at 11.2.6) there apparently has also been a problem reported/fixed with Apple https://ios.gadgethacks.com/how-to/messages-out-order-your-iphone-use-these-fixes-display-conversations-correctly-0182047/


#17

I don’t have it installed on my phone, just the desktop software. I’ll have to try that later, but the reason why i never installed it on the phone is it didn’t seem useful on a phone (since a phone can natively send texts w/o the anywhere app)


#18

There are very valid reasons you would want it on your phone as well. Our anywhere app can sync all of the messages with what you do from your phone and other devices. Otherwise the phone has no idea what the other devices have done. Also the anywhere app was made for our hybrid service so it will work better. We do not work like other carriers, technically speaking.


#19

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.