Republic Anywhere iOS not displaying received images

What phone do you have?
Republic Moto G5 Plus
Experiencing problem on:
iPhone SE 2nd Gen (though this happened on iPod Touch 6th gen as well)

What plan are you on?
Unlimited Talk/Text no Data

Does your plan include data, or just talk & text?


Issue Description

For a very long time now, I haven’t been able to send or receive images on any of my iOS devices. For received messages the placeholder is there but it just says “Tap to Retry Download” I can tap that until I’m blue in the face. I’ve uninstalled, reinstalled, Reset local Content, etc etc. I’m an advanced user so I’m game to try anything. If anyone even wants to take a poke at this… I know Anywhere is no longer being developed but I’m crossing my fingers I can get someone to fix this bug…

I found this Help Article that seems to be something to try

Thanks @jben I already tried the iOS app’s equivalent to that, but no change sadly.

This is a known issue on the recent versions of iOS. As Republic Anywhere is no longer in development I don’t expect that it will be fixed.

1 Like

I didn’t realize that it was a known issue. Most likely it won’t be fix, but I thought I’d ask in the slight chance it might be.

Picture messages on Anywhere broke with iOS and iPadOS 13. iOS and iPad OS are now on version 14 with no improvement.

In all candor picture messaging never worked well on iOS Anywhere clients. One always needed to send the text separately from the text content itself.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer