Republic Anywhere not working on iMac High Sierra


#1

We recently upgraded the operating system on our iMac to Mojave which unfortunately led to several incompatibility issues (printer, MS Office won’t work). After returning to the previous (High Sierra) OS, we now cannot get Republic Anywhere to function. It will load but never gets past the revolving blobs to make it to the conversation list. Any help would be greatly appreciated - we’ve become attached to this texting on the computer feature. Thank you!!


#2

Hi @tracyp.qknums!

You could try to unisntall and reinstall it. If that doesn’t work, you should open a ticket (from this thread ).


#3

Hi @tracyp.qknums,

I currently have Anywhere running on two Macs, one running Mojave, the other still on High Sierra. In this case, I don’t think opening a ticket will necessarily help. Republic’s support for Anywhere currently is limited. More on that here: Official Republic Anywhere Feature Request Thread.

I would go ahead and try uninstalling Anywhere (drag it to the trash), restarting your Mac then reinstalling Anywhere. If that doesn’t do it, please let us know. Sometimes, upgrading and especially then downgrading computer operating systems causes problems with app support files and there’s more we can look at.


#4

Hi Roland, sorry to say it didn’t work - I can download the app but it won’t open. I previously got the rotating green dots but I no longer get anything. I have the icon on my desktop as well as in the dock but still nothing. I really enjoyed this texting program, hope you have some further ideas! thank you


#5

PS - would love to have suggestions for other texting apps which work on iMac as well as android devices. We have both an iMac desktop, Moto G4 and Amazon Fire Tablet. Thank you!!!


#6

Hi @tracyp.qknums ,

Before delving into anything deeper, I’d like to be certain you’ve got the Anywhere app completely uninstalled before downloading and reinstalling. To do so:

  1. Drag to the trash all instances of the Republic Anywhere app on your desktop or in your Mac’s Applications folder.
  2. Let’s also remove it from your Mac’s dock. For that, right click your mouse, select Options then select Remove from Dock.
  3. Restart your Mac.
  4. Download and reinstall Anywhere.

Prior to going here, should merely uninstalling then reinstalling Anywhere continue to be unsuccessful, is your preference to continue to try making Anywhere work on your Mac? Or, would you prefer to discuss alternatives?


#7

Hi, I followed your directions but haven’t re-installed the app yet as I wanted to check with you. The app at this point is gone from desktop and Finder as well as quit and put into trash from the dock. My preference is to keep Republic Anywhere functioning, it was such a pleasure to be able to use it both in my phone and on the iMac. Hope we’re successful! Please advise, thank you!


#8

Hi @tracyp.qknums,

If (as it sounds like) you’ve removed all instances of the Anywhere app from your Mac, placed thern in the trash and (this is key) restarted your Mac, then please download and install Anywhere fresh and see if that solves the issue.

If the above doesn’t solve the issue, do you know how to create new users on your Mac? The reason for doing so would be to test the theory that a corrupted
Anywhere support file in your usual Users folder might be the problem.


#9

I believe I have removed Anywhere from everywhere. I’ll empty the trash too. I’ll do a fresh download from Republic website and let you know, THANKS so much for your help. I don’t know how to create a new user - please send instructions. I only use one log-in and I am the Admin.


#10

You’re most welcome!

Let’s see if the simple reinstall works first.


#11

download went fine but it just sits there in my dock, won’t open or start up. I got the message asking if I want to move it to the Applications folder, I’ve tried both yes move it and no don’t move it, neither made a difference, it won’t open. grrrrrr


#12

I have to be away from my computer for a coupla hours. I’ll follow any further instructions you send in a little later. anxious to get this working again as I loved the convenience of it! Many thanks Roland!


#13

Likewise, I’ll be offline for a bit. I can’t guarantee anything further tonight but will follow-up tomorrow. One question; when you click the Anywhere icon in the dock, does it bounce?


#14

no it doesn’t bounce any more. whenever you’re ready to resume, that’s fine. thanks again


#15

Hi Roland, I have an alt sign-in if it’s needed to try to download the app


#16

Hi @tracyp.qknums,

I’m sorry for the delay in further responding as I’ve been distracted with other things. In theory, if using an alternative account (or the guest account) on your Mac makes Anywhere happy then we know there’s an issue with an Anywhere support file in the account you typically use. Please try Anywhere using the alternate account and let us know the result.


#17

yes, alternate account worked! thanks Roland. now what to do?


#18

Hi @tracyp.qknums,

Now we try to eradicate the support file(s) causing the problem. The first suggestion is non-destructive, the second is not, so if the first works stop there. Please know when I say destructive, I mean to Anywhere data on your Mac not to your Mac or anything on your Republic phone.

  1. Sign back into the account you typically use.
  2. From the Finder’s Go Menu, select Go to Folder…
  3. Type ~/Library/Preferences
  4. Locate com.republicwireless.anywhere.helper.plist and com.republicwireless.anywhere.plist.
  5. Drag those to the trash, then restart your Mac.
  6. Test Anywhere.

That’s the non-destructive option to try. If that doesn’t get the job done, it’s on to destructive. You’ll lose text messages saved on your Mac but if things go according to plan you’ll be able to launch Anywhere and restore the last 30 days of text messaging content. Nothing will be removed from your Republic phone. Please see Republic’s guidance here for the how to:


#19

Hi Roland, I have 2 Anywhere files in the library cache but neither has the name you listed. here are the names I found:
com.republicwireless.anywhere.ShipIt
com.republicwireless.anywhere
I will drag these files to trash if that’s the next step. I don’t find the file names you listed.


#20

Hi @tracyp.qknums,

It’s possible your Mac is hiding the .plist file extensions. In and of itself, this isn’t important. So long as what you found is inside the Preferences folder, please trash them, restart your Mac and see if doing so makes Anywhere happy again.