Republic Anywhere not working on MacOS High Sierra


What phone do you have?
-Moto E4+
What plan are you on?
-My Choice Talk and Text
Does your plan include data, or just talk & text?
-No Data just Talk and Text

For a while now, republic anywhere has not been working on my MacBook Pro. I’m guessing it started about the time I installed MacOS High Sierra and I’ve expected the problem to go away in an update to Anywhere. Alas, no such luck has yet befallen me.

Here’s what’s up,

I can sign in without a problem and the right half of the screen displays my last message conversation (as it should). However, the left half of the screen doesn’t display my conversations and If I try to create a new conversation or compose a message on the right half of the screen I get the following message,

Republic Anywhere encountered an error and will now exit. You can first send app diagnostic information.
Provide one-time access to app diagnostic information to help improve troubleshooting.
Exit Send info and exit

(Imagine that last line is what you click to choose your option)

The app quits after choosing one of those options.

I’ve tried logging out and back in. I’ve tried uninstalling the app and reinstalling it. I’ve tried logging out, then uninstalling the app and reinstalling it and logging back in.

No luck

Any suggestions?

Thanks!

Good morning @nathanp.8kczly,

You’ve done a great job writing up exactly what you’re seeing, and I’m sorry none of our other Mac users have chimed in to say whether they are also experiencing this. Thank you for taking the time to report it.

(Do we have any Mac users among our @Ambassadors or @Experts?)

Could you please open a Support ticket with this information? You can do so here: Tickets | Republic Wireless

If you have any trouble opening a ticket, just let me know and I’ll open one on your behalf.

1 Like

I’m not a Mac user, but try uninstalling it again, but go into where it was installed and remove any leftover files (such as config files) that might cause the problem to persist on the reinstall. Then try installing again.

Unfortunately, one won’t find those files where a Mac app is installed. If need be I can direct @nathanp.8kczly to them. First, I’d like to suggest some general Mac troubleshooting.

First I suggest opening the Mac’s Activity Monitor app. For those more familiar with Windows, it’s the equivalent of the Task Manager. You’ll find it in the Utilities folder. In the search box (upper right) enter “anywhere”. On my Mac (also running High Sierra) I see one instance of Republic Anywhere running and two instances of Republic Anywhere Helper. We’re going to kill those. To do so:

  1. Double-click Republic Anywhere.
  2. Click Quit, then Force Quit.
  3. Doing so should terminate all running Anywhere and Anywhere Helper processes.

Next, repair your Mac’s startup disk as described by Apple here: https://support.apple.com/guide/disk-utility/repair-a-disk-dskutl1040/mac.

Finally, restart the Mac and let us know if Anywhere’s behavior has improved.

1 Like

Ah yeah, your right. I knew this but just didn’t know exactly where. Unless it’s the same location as on Linux.

Thanks for the suggestion. I tried it but so far I’ve had no luck. Two disks appeared in disk utility, MacintoshHD, and OS X Base System. I tried repairing both and OS X Base was fine but it said it was unable to unmount and perform the first aid operation on MacintoshHD. After restarting the computer the problem still persisted. Should I look into figuring out why I couldn’t run first-aid on MacintoshHD?

I also tried searching and deleting all files related to republic anywhere through finder by searching under “this mac”. Upon reinstallation, the problem persists.

Thanks again.

You’re welcome!

Sorry to hear that!

In order to “repair” your Mac’s startup disk (Macintosh HD), you cannot start the Mac from it. Please do as Apple suggests and print the instructions I linked out, then start with step 2.

Finder may not find all support files associated with Republic Anywhere. I know where most (if not all) of them are, however, deleting everything won’t necessarily help and may cause harm. Among the things one might inadvertantly delete is Anywhere’s local database storage meaning you’d lose any text messages on the Mac older than 30 days.

Some additional thoughts.

When you refer to reinstallation, I presume you mean trashing the Anywhere app, then copying the app back. Are you downloading a fresh copy of Anywhere when doing so?

Do you know how to create an additional user on your Mac? Doing so, then installing Anywhere when signed into that user account would tell us if there might be a corrupted file somewhere in one of your usual user account’s directories. Apple’s guidance for creating new user accounts is here: https://support.apple.com/kb/PH25796?locale=en_US&viewlocale=en_US. Though it references Sierra rather than High Sierra, the process hasn’t changed.

Okie Dokie Lokie, Lets try it again.

Followed linked instructions and repaired startup disk Macintosh HD. Upon restarting the computer unfortunately Anywhere’s behavior has not changed.

Yes I’ve been redownloading Anywhere when reinstalling.

I also tried creating a second user redownloading Anywhere on that profile. (Great idea by the way.) The issue persists under the new user as well.

I’m not a computer guru, but I’m gathering that the problem seems to be on my computer not the app itself. Should i just hard reset my computer and start over?

OK, so the quick fix for corrupted files didn’t do the trick. Thanks for being willing to try.

Again, apologies for asking the obvious.

This tells us the issue is not a corrupted Anywhere support file in either of your User folders (directories), which is why your previous attempts to delete them (even if you got everything) didn’t help.

With your help, I’ve been trying to rule that in or out. We’re not there yet. Please don’t “hard reset” your Mac. Reinstalling a computer operating system isn’t trivial and I’m not convinced it will solve your issue. I need to poke around to see if there might be Anywhere support files outside the Users folder now that we’ve ruled out something going on there. That said, are you having issues with any apps on your Mac besides Anywhere?

It’s also possible the issue is specific to your Republic account for some reason. If you haven’t already done so, please go ahead and raise the help ticket @southpaw suggested. It may help to link this thread in that help ticket.

I also want to be certain we’ve covered that you do see these text message conversations on your phone? It’s just the Mac where you don’t see them, correct?

1 Like

Thanks for taking the time to give me a hand.

I haven’t noticed any other problems. Although I suppose that doesn’t mean they aren’t hiding somewhere.

That is correct. I haven’t had any problems with Android or iOS.

Thanks for your patience!

P.S. A help ticket has been opened.

1 Like

I picked up a cheap refurb vanilla MacBook 2010 version last week to play around with. With the latest Sierra updates the RWA app worked as advertised.

After reading this in the a.m upgraded to HS this p.m. to see if Anywhere would still work. Initially had an issue. Fumbled around clearing previous downloads and deleting the Anywhere program. Reinstalled it and it works fine again.

Doesn’t appear to be a RWA/HS specific issue. No advice to offer as I’m new to modern Macs. my last one was a laptop purchased in '98 or '99 and haven’t used Macs for the last 15 years. Good luck with yours.

:flight_departure:

1 Like

I also just switched to High Sierra on a MacBook Pro and Republic Anywhere stopped working. I removed the application and re-installed, but I get noting at all. The Republic Anywhere items appear in the admin bar, but no texts are launched. I loved this app. as I didn’t have to have my phone to get login codes etc. Hope Republic gets it working with High Sierra soon!

Hi @ruthp.zcswh5,

If you haven’t already, would you mind opening a ticket on the matter? If it’ll work well enough to allow it, opening a ticket from the Anywhere app on the computer would be very helpful. After describing what you’re experiencing, please ask them to investigate your ticket as part of master ticket #1225291.

(Tagging @Ambassadors for situational awareness.)

3 Likes

I’m going to mark this topic as solved because it looks like our developers were able to resolve the issue in an update in late April. If anyone continues to have this same issue with Republic Anywhere on High Sierra, please do let us know.

Sorry to be bumping such an old topic, but I did want to follow up to indicate it has been solved.

2 Likes
Message an
Expert customer