Republic Anywhere on Linux: Disconnecting and Reconnecting


#1

Laptop

Package:

1.5.9 (main)

OS:

Ubuntu 18.04

Kernel:

4.15.0-38-generic

Issue Description

I have two workstations, one desktop, one laptop. Both are virtually identical in terms of install (but not hardware). The desktop has no problems at this time. On launching Republic Anywhere I may be alerted that it cannot connect to the Internet, but this usually disappears on retrying the connection.

Once I login the application constantly flips between being connected and disconnected. The message is shared at the bottom of the screen and reads: “Currently not connected”.

While connected, I can send messages.

This happens on two different networks, one at home, one at school. The desktop, at home, has no such problems. As far as I can tell, nothing is being logged after tailing the log directory for a time.

Nothing is logged in the router’s firewall.

I have attempted to uninstall (apt remove republicanywhere and apt purge republicanywhere) and remove all user data related to Republic Anywhere on the laptop (the only data I can find is in ~/.config/Republic Anywhere followed by a reinstall, but there is no change.

I also attempted to install the stable branch by modifying /etc/apt/source.list.d/republicanywhere to see if there was any difference, but to no avail. Installing the stable branch on the desktop also yielded no issues and it continues to work properly.

I have disabled my firewall (CSF) but have seen no change with this.

The installation of the software is based on the following:

Any advice on which logs to follow or possible troubleshooting steps? Anyone experiencing this or have experienced it and found a solution?


#2

In my experience this happens when you put a Linux device to sleep. If this happens the only fix is the restart the device. (In my experience.)

I believe it has something to do with how Linux handles putting devices to sleep, especially newer hardware. Ryzen systems are known for having issues with sleep if you are rocking a Ryzen cpu.


#3

Thanks! Good ideas! Some more information on the situation for those who face something similar or who want to know more.

The laptop is rocking a classy i5-3210M and is facing this issue from a clean boot.

The only thing I can think of in any remote connection to it going to sleep would be that it is a dual-boot-capable laptop. I disabled sleep mode sometime ago to avoid various sleep-related issues, as well as Windoze fastboot.

I’ve tested it on the Windoze install; no problems there which suggests to me that it is not the wifi adapter. An MTR likewise shows no packet drop.

Running the application from the CLI reports the following debug information which repeats ad inifitum.

Debug
debug: HANDLER handling ipc request MARK_CURRENT_CONVERSATION:id-num-ber2
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.reconnect
info: MQTT[setupMqtt-id-num-ber] mqtt.connect
verbose: MQTT[setupMqtt-id-num-ber] event=mqtt.offline
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.close
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.reconnect
info: MQTT[setupMqtt-id-num-ber] mqtt.connect
verbose: MQTT[setupMqtt-id-num-ber] event=mqtt.offline
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.close
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.reconnect
info: MQTT[setupMqtt-id-num-ber] mqtt.connect
verbose: MQTT[setupMqtt-id-num-ber] event=mqtt.offline
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.close
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.reconnect
info: MQTT[setupMqtt-id-num-ber] mqtt.connect
verbose: MQTT[setupMqtt-id-num-ber] event=mqtt.offline
debug: MQTT[setupMqtt-id-num-ber] event=mqtt.close

I restarted for good measure and the problem persists in the Linux install. I will have to fiddle with it some more and see if I can’t find what’s happening. Messages are not updating on the machine, likely due to the inability to connect.


#4

That’s why I mentioned that it might be something to do with how Linux handles sleep.

You can disable Windows Fast Boot in the control panel under power options (on windows). This should save you a lot of headache and open you up to accessing your Windows partition safely from Linux.

Can definitely cross out sleep then.

My best guess at this point is that this is an issue with Ubuntu 18.04 that hasn’t really affected anyone till now.


#5

#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.