Republic Anywhere update 1.1.8 problems

the first few versions worked great and the latest is not working well -

  • will not start
  • will give one the ‘windows waiting wheel’ for about 30 seconds and then close
  • if the window even opens it just shows the ‘starting wheel’ and never runs
  • will not remember my login information (if it starts) and i must retype every time

1 out of 4 times if i restart the computers (i have many computers and running both W7 and W10 with the same behaviors mentioned above) and start NO OTHER PROGRAMS the program will start and run correctly. load another program first and Anywhere is nowhere.

how does one get the original release? that WORKED!!

I just redownload the Anywhere install when it becomes non-responsive.
Republic :anywhere: Anywhere installer for Windows

I have noticed these two as well.

I’ve had a few issues with this version too but I can’t say which events lead up to them. On a couple of occasions the app has crashed while minimized to the task bar and on a couple of occasions it has lost it’s connection to RW only to regain the connection when I close the login dialog box. The latter situation is different from the situation that occurs on start-up with my notebook where the app tries to log in before WiFi is ready. In this new case the login dialog box is appearing spontaneously on my desktop computer which has a direct connection to my router and not associated with start-up.

I see the problem (login screen reappears, app spins forever) consistently when I put my laptop to sleep and then resume. I have to completely close (exit) the Republic Anywhere app, and then restart it, and then it works again. I have reported it through some help tickets, and it seems to be a known and reproducible problem, which still exists in 1.1.8. I suspect it has something to do with the WiFi network connection - perhaps the window of time required to restore the connection.

Staff has said that’s the exact issue. Basically, the app starts up and tries to log-in before the internet connection is reestablished, causing the log-in to fail and the login screen to appear. You should be able to cancel the log-in prompt and then open the RWA App and find that it is already logged in.

Actually, if you “cancel” the login prompt (click on the “X” in the upper right), a dialog comes up asking to send in an error report, and then it exits. If you select “Exit” in the menus, however, it just exits quietly. Then if you restart the app, everything comes up fine, without having to re-enter login credentials. It’s just kind of a pain to have to exit and restart it every time I sleep/resume my laptop.

2 Likes

@flarewatcher If you ignore the login window entirely and instead access the Anywhere icon from the system tray in the bottom right corner of the task bar, does it open successfully?

Also, have you opened any tickets with support regarding the experience? If so, if you can give me the ticket ID I can track it down within our system and place it on our master ticket tracking this issue.

2 Likes

I also see the login window from time to time… on Windows 10. Sometimes you can dismiss it and relaunch…but other times, you do need to re-login to get back in to Anywhere. I don’t use Anywhere on a daily basis…but it is annoying to keep punching in the credentials over and over again. I haven’t found a causal way to reproduce the error…so didn’t submit a help ticket. There was a crash the other day…where I did “Submit and exit”

My “main” ticket number is 1 1 6 1 7 1 7, but I believe it is already linked to the master ticket number. Support seems to be fully aware of the issue and are able to reproduce it, although at this time they are not yet able to offer any updates regarding a solution. It’s not unusable, just an inconvenience, but hopefully they are on the trail of a fix - maybe in the next release?

separate the ticket number out by spaces…or you can use the </> button in the editor to make the number visible as is.

Thanks. Number now appears to be visible.

1 Like

1.1.9 should be hitting a Mac or PC near you any time now:

2 Likes

Well, I was hopeful, but 1.1.9 didn’t fix the problem. Still seeing the exact same behavior after sleep/resume. I’ll post an update to my ticket.

I found your ticket: 1 1 6 1 7 1 7 and it is attached to our bug regarding the login window appearing when the desktop wakes from sleep.

However, our bug ticket for that issue does not encompass the experience of the crash when the login window is closed out. I’ll open a new bug ticket for tracking that particular experience, as I was able to replicate the issue on demand via my windows 10 desktop as well.

3 Likes

Great, thank you!

Good news! As per the release notes, the newest version of Republic Anywhere (1.2.12) seems to have fixed the issue with the program not resuming correctly after the computer sleeps/resumes. The login window no longer pops up, and the conversation window comes back correctly with all the recent conversations listed. I’m a happy camper!

5 Likes

I have seen similar improved performance going in and out of sleep in the past few days. No more crashes or login screens resuming from sleep on a Win 10 desktop.

1 Like
Message an
Expert customer