Republic app and galaxy a51 compatability

What phone do you have? galaxy a51

What plan are you on? not sure

Does your plan include data, or just talk & text?
Includes 1 g of data every month


Issue Description

been several weeks now. My phone suddenly starts dropping calls and texts. Solution has been to delete republic app and reinstall. Had a ticket and thought it was finally fixed but it seems every week I have this same issue arise. Make a call and get a " you are not connected to a netwoek" make emergency calls only. Start to type text and it closes out. If a call goes thru it shows a wrong number on recipients phone. Starting to wonder if I need a new phone thats more compatable or a different carrier. Sure would love some advice here. Republic has been very helpful but the problem persists.

Jim

Without knowing what you’ve tried, I would direct you to:

With particular regard to:
3. Ensure the Republic Wireless app is not put to sleep by the Samsung operating system

2 Likes

Thanks for your reply. So far my phone has been diagnosed by a republic worker who eventually deleted the republic app, re applied it , disconnected my phone from republic network, re established the connection to the network, restarted the phone, had me be sure it was set so the app would not be put to sleep. That worked. Several days later this again went south . Again it was to delete the app and re install it and go through all the things involved including making sure the app is not put tp sleep.
Now I know what gets me back on line so I can use my phone. Uninstall the app and reinstall it. I always go thru the process of making sure the republic app is set so it can not be put to sleep. Still my problem persists. I also have an issue where my phone will shut off using wifi for calls. I get a warning and this is easily fixed.
I hope this provides what information is needed for suggestions etc… sorry for the letter length but that covers most of what I remember being done.
Thank you,
Jim

Message an
Expert customer