Republic app not compatible with Google Call Screening


#1

The republic app is not compatible with Google Call Screening (new functionality in Android Pie) because it will not release the microphone. Is there any way to get the Republic app to release the microphone and allow Google Call Screening to work?

Is an update to the Republic app possible?

Thanks


#2

This is a Google bug. More info here: Google's new Call Screening

I should mention that if the call comes in over cellular rather than wifi, it’ll work fine.


#3

Any way to set up Our Phones so that calls always go over cell but Wifi is turned on for data?


#4

There isn’t on the phone. How comfortable are you with accessing your router and blocking ports? You could block the ports necessary for wifi calling there, forcing calls over cellular.


#5

This is something that I could try. I have a Asus RT-86U and know access the router admin screens and make changes, but I don’t know anything about ports and which ports to block.


#6

Ports republic uses can be found in the Router tweaks tips

5090 UDP which is used for call set up
6000-29999 UDP which is used for voice/audio
443 MQTT which is used for Voicemail, Messaging SMS/MMS and keep-alive messages to RW servers. (some 2.0 Phones will continue to use 8883 until a config refresh *#*#8647#*#* is done, and the DEFY will continue to use 8883)
NOTE: Most firewalls are stateful, meaning they allow two-way communication as long as it is initiated by a client (phone) that is inside the router’s network. This could be your home, school or office router/firewall
Republic phones will always send the initial voice/audio data packet to a destination port of 6000-29999 (regardless of who placed the call)
Note1: A 3rd party site provides the ability to test that the outgoing port is open, by use of the following links. You would run these from the browser on your phone
http://portquiz.net:5090 — UDP Call set up
http://portquiz.net:6543 — 6000-29999 UDP for voice/audio, full range may be used, single test port should suffice
Note2: Port Quiz does not test on port 443, however it is the standard port for HTTPS


#7

You only need to block UDP port 5090 to kill Wi-Fi calling.


#8

Thanks,

Sounds like I need to block port
6000-29999 UDP

But Remain open:
5090 UDP shouldn’t matter for WIFI calling so can remain open
443 MQTT should remain open since I want SMS/MMS messages to come through
8883 can remain since I have a family member with a 2.0 phone

However, since I have a family member with a 2.0 phone and is on a WIFI only plan. If I shut off port at router, will his calls come through on 8883 or does his use 6000-29999?

Sounds like I probably can not do this at router and have his phone work through WIFI and mine through Cell, but I am looking forward to your response.


#9

Nope. You only need to block UDP port 5090 to kill Wi-Fi calling.


#11

I agree with this as the other ports are for the audio of an call and not the call setup


#12

Thanks cbwahlstrom, If I block 5090, then WIFI calling will not work for a family member’s 2.0 phone (He is on WIFI only plan) correct? If so, sound like this is not an option for me.
But, I am on a 3.0 plan with WIFI & CELL
he is on a 2.0 plan with WIFI only.

Thanks


#13

Correct, if you block WiFi calling at the router, no Republic phone will be able to use WiFi for calling.


#14

You may be able to block it only for your phone, by MAC address or potentially by IP.


#15

Thanks,

I’ll put in a question on my router’s support forum to see if there is a way to block port by Mac address or IP.


#16

Which router are you using (make/model/version)? - usually found on sticker on the back or bottom


#17

It easy. Set your phone a static ip addres in the router, or it may be called DHCP Reservation. Then in the firewall page, set blacklist option enabled for Network services Filter, enter in your phones ip address as Source, then under port range, 5090, Protocol UDP, then add, apply.
From my Asus AC86U:


#19

That’s why the first step is setting a DHCP reservation.


#20

Thanks SpeedingChetah, set that up on my router and it seems to be working. Calls on my pixel seem to be coming in on cell and I can use Call Screening, other phone on Replublic WIFI only plan is still working. I assume that my Pixel is using wifi data for everything else.


#21

Yes. That is necessary, other wise the phone may get a different IP address at some point later on, thanks to DHCP. If it is set a static IP, then no matter how long the device is disconnected from the AP, it will always get the same IP address when it connects back. And it is that IP that has the Firewall rule set.


#22

Very true, and my only excuse is “Sometimes I forget that I can’t remember everything” :blush: