Republic App says turn on roaming data after installing Android 12

What phone do you have? Galaxy S21+ 5G

What plan are you on? My Choice

Does your plan include data, or just talk & text? 1G data included


After installing Android 12 the Republic app persists in telling me to turn roaming data on even though roaming data is turned on. Restarting the phone does not help.

I have the Galaxy S21 Ultra and after installing Android 12 stable, I get the same error message.

2 Likes

Good to know. I would probably just turn off the message in the Republic Wireless app. Settings > Advanced Settings > Show roaming disabled, until (if) there is a fix.

4 Likes

I opened a ticket just to give support a heads up.

1 Like

I’m seeing this on a Pixel 4 XL with Android 12 also. Given My Choice is about to become a legacy offering and the notification is, apparently, not impacting service, I’d be surprised if Republic’s app were patched to fix it. But, I’ve been wrong before.

S21 Ultra with CDMA. Have the same roaming warning… But in addition, since the upgrade to v.12 the phone will not connect to 4G. It only connects at 3G. On the positive side, it doesn’t show any data usage of my allotted 1 GB mobile plan. Yet an app I installed shows mobile data being used. It’s like unlimited 3G.

Any suggestions?

Keith

Make sure network mode isn’t set to 3G only. I’m not a Samsung guy, but perhaps the following website will help you find the correct setting:

Other than that, maybe remove the SIM card, restart the phone, then reinstall the SIM card.

…and to reiterate the obvious, make sure roaming is, in fact, enabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.