Republic app wont use wifi with VPN on

What phone do you have?
Moto G5+
What plan are you on?
MyChoice App Version 3.29.0.57 Android 8.1.0
Does your plan include data, or just talk & text?
Includes data


So the phone still works and does everything I need, just not optimally, and I’d like to know if this is a known problem or there is a known way to fix this.

The Republic app refuses to use WiFi when the VPN is turned on (Norton Secure VPN). Turn it off and it switches to on wifi with filled in arc. Turn it on and the arc is outline only and says “connected to cellular network” Calls and text still seem to work.

portquiz.net:5090,5060, 29999, 443, etc all seem to indicate open ports.

My wife’s Moto G7 with the same Republic app version and Android 10 does NOT have the problem. This is thru the same home router and same VPN. I initially thought it was a VPN problem, but with the port data and hers working with the same setup, I’m not so sure.

Any idea if there is a known problem or fix?
Any idea if it is a Republic or Android or VPN or Moto problem?
I’d like to be a responsible Republic customer and use WiFi as much as possible.

Mike

Hi @michaels.axr76c,

Your experience is a common one. VPN’s inherently introduce latency into the WiFi connection. As a result of the additional latency, Republic’s app will then determine the WiFi connection to be insufficient to maintain a quality WiFi calling experience and switch that over to cell. Latency alone can be enough, ports need not be blocked. This is how Republic’s app is designed to work.

What is a bit odd is that your wife’s phone is not sharing the experience. I suppose Republic’s app sees something in your wife’s newer phone and Android version that makes WiFi calling with the VPN satisfactory on her phone but not yours.

In any event, there really isn’t anything one might do. Republic’s app, by design, determines if a particular phone’s WiFi connection is sufficient to maintain a quality WiFi calling experience and, if not, moves to cell. There are no end user settings to tweak the app’s opinion. I’m not familiar enough with Norton Secure VPN to advise as to whether it might be tweaked. Some VPNs offer a choice of servers to route traffic through. If Norton Secure VPN offers that choice; are yours and your wife’s phone routing traffic through the same servers?

For what it’s worth, there’s no penalty in terms of additional charges in this context. Republic’s app doesn’t manage a phone’s cell data connection, so wouldn’t interfere with your phone’s use of the VPN secured WiFi for Internet access.

1 Like

I don’t have the ability to choose which VPN server is selected. It automatically picks a server every time it is turned on. However, I checked my wife’s phone and then turned off and on my VPN several times until it selected the same one as hers. Still same result. I do have Android 8 and she has 10, maybe 10 is incompatible with my phone, and that may make a difference. (I update regularly whenever it tells me to.)
I realize there is no real penalty, just trying to optimize things. Sounds like there is nothing I can do, so I’ll just leave it be.
Mike

1 Like

you may want to check out the information/fix provided by this fellow user, No WiFi calling after recent update to Nord VPN - #7 by mikem.pyr6be

1 Like

The most recent update of the Norton VPN included split tunneling. I enabled it and selected the “Phone” app, the “Messages” app and the “Republic” app to not use the VPN. However that didn’t seem to change anything. There is no other app that I can select that is related to phone usage. Anybody have any ideas on how to get Republic to work with Norton VPN?

Check the Notifications provided by Republics App, it may indicate what limitations that the VPN is imposing on you.

So looks like I spoke too soon. After a reboot and a bit of time, with the Phone and Republic app selected to not use the Norton VPN, republic now seems to reliably connect to my WiFi at home.
Mike

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer