Republic overseas to US calls dropping out every few minutes

What phone do you have? Moto 7 Play

What plan are you on? Basic

Does your plan include data, or just talk & text? All


Hi all, and thanks in advance for any help. I’ll try to describe my problem…

I’ve visited my family overseas (in Australia) for the past few years, accompanied by my (old) Republic Moto e (1st Gen.), and had no problems at all making and receiving calls over wi-fi to and from the US.

Fast forward to 2020 and the age of Covid-19 restrictions, with my aging parents now locked away in a aged care facility… I had the idea of sending them a Republic phone so we could talk to each other, so I purchased a new Moto e, signed up for a new basic plan with a new phone number, and sent the phone off to my Dad.
It took a longwhile to get there, but finally I got a call from him, and we’ve had a few more conversations over the last few weeks.

The problem is that recently, when I try to call, I often get an announcement that ‘the Republic member you are trying to call is unavailable’. Or if the call goes through, the connection suddenly drops out after two or three minutes. Sometimes I can call back and reconnect, and sometimes I just get the dreaded message again, but even with a successful connection, the dropouts keep happening regularly.

My Dad is a big internet buff, and had no trouble getting a good w-ifi connection for the phone, but I’m afraid his patience will run out if these dropouts can’t be solved.

Can anyone think of a reason why these dropouts are occurring, and what we could try to fix it?

–thanks for your help!

I would start troubleshooting (which may be iterative and a bit of a time sink. on his part…

  • First step would be to put the phone in Airplane mode and then Turn WiFi back on … this will eliminate the possibility that the phone is trying to hand over to the nonexistent Cell.
    • Downside is he will see Open Arc, as AP mode doesn’t allow RW to update to the solid Arc when the WiFi connection is made so it would be best if you make the connection with him then talk him through the change and see if that makes the call last longer
  • The not being able to connect to him, is possibly another problem, but lets tackle later
2 Likes

I think you will get some thoughts but maybe no solution… I recently took my moto E first gen out of mothballs and added it back on with the legacy 5 dollar WiFi plan. I had to strip apps down to the very bare minimum… I plan to do some traveling in 2021 and need the reliability and ease of connection of WiFi only… The E1 will make reliable calls even on most restricted and low quality internet connections…

Thank you both very much for your helpful replies.

jben, I’ll try what you suggest and see how it pans out. Funny though, i didn’t have the problem years ago with my Moto e 1. Has anything changed, either in the phones or in the service, that might create this issue?

I’ll post an update soon.

–thanks again!

So, jben – on my Moto 7 play, when I turn Airplane mode ON, the Wi-Fi switch goes OFF. Then, if I turn the Wi-Fi switch back ON, the Airplane Mode switch stays ON - both switches are ON.
Is that what you are describing, for my Dad to try? Should we try it with BOTH phones?

The last few times I’ve tried calling, I can’t even get a connection - I just get the ‘the RW customer you are trying to call is unavailable’ message 8>[

–thanks

I wouldn’t worry about your end.

  • Yes the Airplane Mode will stay on and the RW Arc will show Open.
    • Now when you turn the Wi-Fi switch back on, it will make the connection but the indicators will not change
  • To be sure we don’t run into the problem where Google’s Doze turns you r WiFi off for you to save battery, arrange for him to have the phone on the charger (that’s the only true way to turn off Doze afik)

Have you ever tried using another communication app like Google Duo? I just say this as a means to make sure your dad’s connection is up to snuff for real time communications.

Thanks jben, I’ll pass that along to him.

-cheers

Thanks for the suggestion. I’ll keep it in mind, but for now I’m trying to keep things to what I know (and thought) already worked for me before.

–cheers

Message an
Expert customer