Republic Wireless ARC is empty

This may have been like this for a while, but I just not noticed my R.W. arc icon is empty in the upper left of my screen.
I applied the latest Android 12 January 5, 2022 Security Update this morning to my Pixel 4a/5g.
This got my phone to Build SQ1A.220105.002.
After reboot, the RW arc is still empty.
It says: “On WIFI Calls over cell, messages and data over WIFI”.
There is no SSID listed. I have two SSIDs available at home, so I tried switching to the other one, and I get the same message.
I am on the “My Choice + 1gb” plan with a GSM SIM with RW App version 3.30.4.1.
Texting and calls seem to work fine, and I have a good internet connection (275Mbps down/ 11 up tested on the phone itself).

Thanks very much!

Hello,
See if this note helps.

Do you happen to use a VPN? Many VPN’s will cause the condition of “On WIFI Calls over cell, messages and data over WIFI.” As long as you can make/receive calls I wouldn’t get too worried about it.

No VPN on the phone or the router I connect to. I may try rebooting my router this afternoon to see if that fixes it. I applied the newest firmware to the TP-Link router (which caused a reboot), still no filled in R.W. Arc.
I also restarted the phone several times and still no filled in arc. It is working, so I will not worry about it!
Thanks for all the help!

1 Like

Since you’re on a My Choice plan, you might check and turn off the manufacturers’ WiFi calling if it was inadvertently/automatically turned on:

  1. Tap Settings from the app drawer
  2. Tap Network & internet
  3. Tap SIMs
  4. Tap WiFi calling
  5. Slide the toggle switch to turn WiFi Calling off

Good Morning @muerte33,

What you describe is how Republic’s app is designed to behave. Republic’s app is not designed to keep calls on WiFi at all costs. Republic’s app is designed to keep calls on WiFi first unless it detects something on the WiFi network that would lead to inadequate results if calls were routed over that WiFi network.

Further, it may not be an issue with your WiFi network per se. One’s WiFi network is only as good as the underlying Internet service providing it. I understand you have more than adequate network speeds. Network speed, however, isn’t the only determining factor of network quality for voice communication. Packet loss, latency and jitter all play roles as well.

I mention all this because periodically, I see the open arc condition on multiple Republic phones in my household from time to time also. I troubleshooted until the cows came home with no success. I then noticed that typically the condition tended to occur in the morning (possibly overnight) and tended to clear up as the day progressed. I finally concluded the source of the problem was my home network’s underlying Internet service. Since, I generally have adequate cell coverage for voice and text messaging, I now just let the underlying Internet access sort itself out.

All of the above said, power cycling your network equipment would be the next logical step if things haven’t already sorted by this afternoon.

3 Likes

Thanks for that tip, but I looked under Sims on my Pixel 4a/5g, and there is no “WIFI Calling” option.

I have seen it go out in the past, and like I said I just noticed it this morning when I was about to apply the Security Updates. Thanks Rolandh, I’ll just keep an eye on it. Both our R.W. phones are doing the same thing this a.m. (empty arc), but both are the same too (Pixel 4a/5g).

Sounds like you’ve done what you could. Carry on. @jben, the conqueror of empty arcs, may have further input.

3 Likes

Thanks for the plug … so let me put one in for Router Tweaks which is a collection of information gathered over the years from this community and other sources.

2 Likes

Wow, that was a great post JBEN! I did notice that SIP ALG was enabled on my router, but I have an Obihai device that might need that?

Absolutely not. The standard recommendation in the broader VoIP community is to turn SIP ALG off.

2 Likes

I made those changes to the router (turned off SIP ALG), but it did not “fill” the arc. Later in the night I saw it sporadically go solid to empty, but this a.m., it is solid. I tested the Xfinity connection throughout the day, and ping was < 30ms and jitter was usually < 5ms.
Thanks for the help everyone!
This one can be closed out!

3 Likes