Ringer goes to "alarm only"

Every Saturday I find that my phone ringer has switched to “Alarm Only”.
Only on Saturdays.

This is problematic because I start a 24 hour on call shift for my job at 5 AM.
Although it vibrates, that’s not enough to wake me, usually
Occasionally, my shift is 48 hours through Sunday but this happens only on Saturday

It’s easy enough to fix, once discovered.

The only thing I can figure that’s different on Saturdays is that the phone isn’t on my desk overnight but near where I sleep, maybe, 12’ away from the router.
Usually, it sits on my desk 6" from the router

Is there some secret setting that has the phone determine most normal people want to sleep later on Saturday and turns the ringer off?

I have a Moto G4 Play and have all updates

Thank you

Sounds like you may have a downtime setup [via the Android settings, or the Moto app.
For Android settings check
Settings–>Sounds and notifications–>interruptions
And see what down time is set up
For the Moto App open the app and tap the menu icon in the upper right [I have it as a gear some have it as 3 vertical dots or 3 horizontal bars] then the assist section

Tanks for the information.
There doesn’t seem to be anything in the Moto app.

In the Android app, there is something called “Priority Only Allows” under “Do Not Disturb”.

I’m not sure if this should be set to “anyone” or "no one"
I do not have an “interruption” option

Do you see Settings -> Sound & notification -> Do not disturb? For me Priority only allows is set to allow Alarms, reminders and events.

Since this seems to be happening on a schedule for you, what if anything do you see under Automatic rules, particularly under Weekend?

Thank you, rolandh.

Under “Do Not Disturb” there are 2 things; Priority Only Allows and Automatic Rules.
Under Priority allows, Alarms is turned on and grayed out
Reminders is off
Events is on
Messages is set to From Anyone
Calls is set to From Anyone
I changed the previous 2 this morning but not sure if this is correct.

Repeat Callers is set off and grayed out.

Under Automatic Rules:
Weekend and Weeknight is off
Event is On
Rule Name "Events"
During Events for Any calendar
Where reply is Yes or Maybe
Do Not Disturb is Alarms Only

Do you have your On Call shift on your calendar? That’s what messed me up. I had to turn that Events rule off or otherwise it would stop receiving calls when I had non-meeting meetings on my calendar.

I do have that on my calendar but have lots of things on it, theresar.

I just turned “Events” off in Do Not Disturb

Is that correct or backwards?
Thank you

That’s what worked for me. I hope it resolves your problem as well.

The only downside is that I still haven’t figured out a way to automatically go to silent during work meetings during the day, but not off-hours.

It’s not automatic but I just turn the volume off manually.
Of course, I need to remember to turn it back on

You also use an app like Shush! or something similar to turn the ringer back in case you forget.

Message an
Expert customer