RW app not accepting WiFi connection?

Like any good RW customer, I use WiFi whenever possible. My super-cool Samsung S7 automatically switches to the networks it has learned, such as all the local grocery and hardware stores I go to, many restaurants, and my home network. I always observe the little RW bar icon go from an outline to a solid arc and know I’ve got free data!

This weekend I took a trip and stayed at a large chain high-end hotel with free WiFi… I don’t want to stir up trouble so I won’t call them out by name, but it was a fancy place. Their free WiFi channel was called “{chain name}_GUEST” and didn’t require a password. Going to the settings page on my phone and tapping on WiFi I was easily able to connect to it. Strangely, though, even as my phone was telling me it was connected to WiFi, the RW logo did not turn solid and it reported me as being connected to cell the whole time I was there. I tried rebooting and reconnecting but nothing worked.

Was there something else I could have done? The concierge at the front desk said that as far as he knew, the WiFi was working fine and they’d had no complaints. As I said before, I’ve used dozens of public WiFi networks without any trouble, even in foreign countries. This is the first time I’ve connected to a WiFi network and had RW not recognize the connection. I’m at a loss to explain it.

In case it should happen again in my travels, I’d appreciate any tips you can offer!

  • = M = -

I’ve never been in a hotel chain that doesn’t require you to open a browser and accept the terms and conditions or enter your room number and last name to get access.

The chains I can verify require this are: Hilton, Marriott, Intercontinental, Hyatt, Aloft, Holiday Inn, Residence Inn, Extended Stay America, Homewood Suites, Embassy Suites, Staybridge Suites and Fairfield Inn.

My assumption is that once connected to wifi you needed to open a browser and connect to the authentication page that likely would have required you to enter your room number and last name and THEN then phone would have had internet access.

2 Likes

Well, the hotel I stayed in is on your list, so this was obviously the problem. Their network never made me do any sort of authentication when I connected. The people at the front desk just told me it was free and required no password, and not that I needed to do anything else. Next time, I’ll hunt down someone with better IT knowledge and get the right instructions!

Thanks, louisdi, for your quick and helpful answer! :grinning: Now I know!

  • = M = -

If you see no internet connection and the phone isn’t prompting you to authenticate, it is generally safe to try and navigate to a website to see if the network will redirect you to the authentication page. I generally use “aol.com” as it isn’t an https site so doesn’t throw the type of errors that trying to navigate to google.com and then being redirected does. If that doesn’t work, another trick is to try navigating to “1.1.1.1” and seeing if that brings up the authentication/sign-in page.

2 Likes

Awesome! I will definitely try this next time if I have this sort of trouble. Most appreciated!

  • = M = -

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer