S7 Edge domestic data roaming setting


#1

What phone do you have? Samsung Galaxy S7 Edge

What plan are you on? My Choice

Does your plan include data, or just talk & text? talk & text


Issue Description

I’m on the CDMA carrier. Whenever I restart my phone and then go into Settings/Connections/Mobile Networks/Data roaming, domestic data roaming is always switched off. All of the roaming guard settings are switched off, and all of the other roaming options are switched on.

I thought maybe it was a setting when I was using the NetGuard app, because there are so many options, so I uninstalled it, and tried No Root Firewall, which I had used in the past, but the interface was so much nicer looking with NetGuard. The domestic data roaming still gets switched off on reboot. So I uninstalled that, did a system cache wipe, and it still does it. I don’t use any security/antivirus apps. Not sure what to try next to keep domestic data roaming switched on. I also tried ##72786# and a profile/prl update.

edit - I tried Safe Mode…domestic data roaming still off. I did notice that in the APNs in safe mode, APN2 LTE internet n.b7.ispsn is selected. But when not in safe mode, no APN is selected. Should I choose that one? Side note…safe mode is a drag. LOL. When I changed back to normal mode, some of my defaults (keyboard, text app) were messed up.


#2

For some reason Samsung S7 Edge after a restart or an OS update, it defaults Data Roaming to Off and turns on Roaming Guard.

Does it turn on when you tap on the switch? If it does, turn Data Roaming back on and then tap on Roaming Guard and turn it off.

APN2 LTE is fine. I agree Safe Mode is a pain and messes with your keyboard and texting app. But then again Safe Mode does set the phone back to defaults, which mean Samsung Keyboard and Texting App. You’ll have to reset them yourself.

I’ll be out for several hours, but please let us know how you’re making out with the phone.


#3

Thanks for the reply. I slept all day…I’m prone to reverse-cycling (up all night, sleep all day). LOL. I just finished with the April security update on my phone that came out today, and did another cache wipe after. I set the APN to the APN2 LTE. But still upon reboot, all the roaming guards are still off (they always were), but that ONE setting in Data Roaming still gets turned off (Domestic data). All the other roaming settings remain on (Domestic voice, International voice and data, GSM Networks data).


#4

When you flip the switch will it turn on?

Check In Settings
Tap on Data Usage
Mobile Data should be ON,

Also check In Settings
Tap on Software Update
Tap on Update PRL
Tap on Update Profile

Restart the phone and reset all Data Roaming to ON and turn OFF ALL Roaming Guard
Tap on Roaming Network, it should be set to Automatic

All the settings should stick until the next OS update or if you turn the phone off and on.

Also a good reminder is to open the Republic Wireless app
Tap on Settings
Tap on Advanced Settings
Check the boxes for:
Show cellular data disabled and Show roaming disabled

RW app will remind you if the settings go back to default Roaming OFF

Just so you know, every time you clear Android System Cache the phone will go back to the default Data settings.


#5

Thanks for your reply. All those settings are correct. I did the profile/prl update that I mentioned above yet again, restarted, again turned off the roaming guards, turned on all the roaming options, restarted the phone again, and the domestic data roaming setting again did not survive the restart process. Nor did the RW app tell me that data roaming was off.

One thing I didn’t do yet was uninstall/reinstall the RW app. I’m kinda assuming I’ll lose all the spam numbers I put in manually to be blocked.


#6

The Data Roaming switch won’t survive the restart process, Samsung turns it off as default.

You won’t get a warning from the RW app until you are actually in a roaming area.

Please answer the following questions so I can provide further assistance:

  1. How is your cell coverage?
  2. Do you have a Data plan?
  3. Are you able to use the internet when WiFi is not available?
  4. Are you having issues with sending MMS or text messages when away from WiFi.
  5. Are you able to make and receive calls while away from WiFi?

You shouldn’t lose your SPAM numbers, since they are stored in Android, But I don’t think uninstalling and reinstalling the app is necessary.


#7

I don’t have a data plan, I don’t leave the house much, so I’m not really sure how good my coverage is. I don’t make many calls. I guess all I needed to know was that Samsung shuts off that one roaming option (of 5 choices) by default, which I couldn’t find in any search I tried. I reboot every few days, so I’ll just have to remember that the data roaming will be turned off, in case I have to text or make a call in a roaming area and RW needs some data to complete. I just thought something was broken, not that Samsung was messing with me. Thanks!

edit- I did uninstall/reinstall the RW app, and my spam numbers I manually entered before were still there, so that was cool.


#8

You’re welcome! I’m glad you asked this question as it may help other members.

Thank you!


#9

Hi @littletoucan and @jumphour,

I need to disagree here, I’m afraid. I’ve just given this a try with the Samsung S7 Edge (GSM-enabled) in our lab. I enable data roaming, then I shut down the phone and restart it. When I navigate back to Settings > Connections > Mobile Networks, Data roaming remains enabled. Am I misunderstanding what you are describing?


#10

@southpaw You can disagree, but it happens to me all the time. Both my phone and @jumphour are on CDMA not GSM. I don’t know if this makes a difference or not. I have seen this question come up a few times with CDMA S7 Edge phones.


#11

@littletoucan, please understand, I’m not disagreeing with the fact that you and @jumphour are seeing it happen. My concern is the statement-as-fact that the setting will not survive a restart because Samsung turns it off by default.
Since that’s behavior I can’t reproduce, I think there must be some other explanation worth unraveling.


#12

This is a screen cap, after a reboot, under Settings> Connections> Mobile Networks> Data Roaming. Is this similar to what you see, but your Domestic Data is toggled on? (your screen is probably white, though).

edit- my arc is hollow only because I forgot I had wifi off when I took the screen cap.


#13

I’m no longer at the office, so it will be Monday before I can compare again. That does not look like the same screen I was seeing., So perhaps we’re on a different OS.


#14

Perhaps we are. I took the OTA yesterday, which was the April security patch. Maybe yours didn’t get updated yet. I’m of course running stock Android 7.0, as this model’s bootloader is locked and incapable of running a custom ROM or anything (SM-G935U). Maybe it’s the free theme I got from the Galaxy App store that’s throwing you (because it’s not white. It didn’t affect the data roaming toggle issue at all.)


#15

No, I understood about it not being white! I’ll take another look Monday. @littletoucan, are you seeing the same screen as @jumphour?


#16

Thanks @southpaw. I’m in no rush, and I know I can just flip the data roaming switch to ‘on’, but if it’s not normal, maybe it can be fixed somehow. I’m not bored enough to do a factory reset yet (I got one of those fancy Samsung VR headset thingies, and there are HUGE games that I just don’t feel like downloading and reinstalling again yet. LOL).


#17

@southpaw My screen is the same with the exception of it being white.

This has happened to me since I purchased the phone from RW last year. I don’t see the point in doing a factory reset since the phone works just fine.


#18

@littletoucan, if it’s not too much trouble, could you perhaps fly to Korea and make Samsung fix it? I can just remember to flip the toggle, but it makes my eye twitch. :wink: (and I’ve honestly already forgotten how I even noticed it in the first place.)


#19

:rofl: I just did the April security patch and low and behold Data was turned off on my phone too! I also have the same plan as you do. Whether I have a data plan or not, the phone does the same thing after a system update. Sometimes all the switches are turned off and Roaming Guard is turned on.


#20

@southpaw Did my usual Monday check for updates and phone restart. Below is what I see after restart.