S7, text issues on cell


#1

Have good coverage here. Voice- perfect. Using either Textra (set up correctly) or Android messenger unable to send or receive text messages. Problem started yesterday. Continues today. Previous text MMS issues that required change to textra were on Wifi only. Not cell. Now it is the opposite. Thanks for your help.


#2

There were some issues over the weekend and after checking the status page, looks like everything is cleared up.

To be on the safe side back up your text messages:

If you have a CDMA SIM, please go to Settings
System Updates
Tap on Update PRL
Tap on Update Profile

If you’re still having issues with texts over cell please do the following:

Clearing Android System Cache:

Clear App Cache too:

Once you’ve completed these steps see if your texts work on cell.


#3

Did all the above, plus reset the credentials, uninstalled and reinstalled the RW ap. Rebooted several times. Anything I missed?


#4

Is data turned on?

Check that data is turned on for the RW app, Textra or Android Messages - whichever one you are currently using.

Are you using a firewall app? If you are turn it off and try texting.

Have you tried uninstalling and reinstalling the texting app with restarting the phone after each step?

What error messages are you getting?

We could try a Soft Reset/Safe Mode, you will need to test the phone with the default app while on cell only:

A. First Power the device off.

B. After power off, Press and hold the Power key.

C. When the Samsung logo is displayed on the screen, release the Power key and immediately hold down the Volume Down key.

D. Hold the volume key till the the device completely reboots.

E. If successful, Safe Mode will appear on the device screen in the bottom left corner.

To exit Safe Mode; power the device off.


#5

Did all the above. Message is “did not send, tap to retry”.

Unfortunately ap will not open/work in safe mode. Seems so strange that it was working perfect on Saturday, I made no changes to the phone, and now no Bueno. Ugh!


#6

Did you try using the default app? it should work in Safe Mode since it’s a system app.

What is your zip code? It’s possible there is a cell tower issue going on. You’re on CDMA, yes?


#7

A few days ago, Samsung prompted me to
"Optomize" the phone, and some security items were added. I’m sure this is the culprit. Now I need to figure out how to uninstall the security stuff. Any ideas?


#8

Ah! Please go to Settings
Tap on Device Maintenance
Tap on Battery
Tap on OFF

For now turn off Battery Saver and see if you can text over cell.

If you can now text and still want to use Battery Saver tap on the middle option.
Then tap on Customize, you’ll see it at the top, might be in blue depending on your Theme
Make sure Background network usage is turned ON
Tap on Apply
Next scroll down to the bottom of the new screen
Tap on Unmonitored apps
Scroll to the bottom of the screen and add the following apps:

Republic Wireless app
Texting app
And any other app you don’t want to be put to sleep.

Test the phone.

Some of the security apps added you need to actually sign up for for them to work. Did you sign up for Knox?


#9

Tried your suggestions, thanks, but no Bueno. Still won’t work. I show a Knox app on the phone, but I do not recall adding it. I can force stop, but not disable it. Force stop will still not allow text over cell.

Sounds like a factory reset?


#10

Did a factory reset. Text worked over cell, great! BUT! Phone didn’t work. Restarted (first time since reset), phone works, now same issue with the text.

I have to think it is something with the RW ap. Tried removing and reinstalling twice. No luck, please help!


#11

Fixed! Deleted ap, restarted.,reinstalled restarted, reset credentials, restarted. Works great now. Thanks for the help!


#12

WOW! So glad you got it working again. Sorry I didn’t get back to you quicker.


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.