Samsung a50 not working after android update 6/30/21

I’m surprised that it just showed up here yesterday. Someone else must have had the problem days (weeks) ago, other than me.

I’m going to need a new SIM card, my Sim card I got just last month is not recognized on my phone anymore.

1 Like

Hi @donsvg,

It is an issue we are investigating as a bug. We do not yet have a solution. As soon as we do, we will share it in each ticket that has been attached to the bug (yours is currently the only one), here in Community, and in our Help Center.

No. You were the first person to bring to our attention that the Android update for Android R was available to the Samsung A50. These updates often roll out slowly - hitting a few phones at a time. You can thank Samsung for rolling the update out to your phone so early.

My apologies, it was wishful thinking that the below announcement covered a problem that sounded identical here.

Jul 1, 2021

Provisioning Issues

Resolved - This incident has been resolved.
Jul 1, 19:54 EDT

Monitoring - A fix has been implemented and we are monitoring the results.
Jul 1, 15:27 EDT

Identified - The issue has been identified and a fix is being implemented.
Jul 1, 13:51 EDT

Investigating - We are currently investigating reports of provisioning issues with one of our cellular partners . We’ll provide updates here when we have more information. We apologize for any inconvenience this has caused and thank you for your patience.
Jul 1, 12:15 EDT

I see. I’m sorry that was ambiguous. A “provisioning issue” usually means that phones cannot be activated, and numbers cannot be assigned. Anything we list as an "outage’ is affecting very large numbers of people and is not typically restricted to just one or two phone models.

5 posts were split to a new topic: Republic needs to work better with Samsung phones

Hi @jennifers.lyg4dg,

I notice that your help ticket on this matter is now marked solved. Is your phone now working correctly?

@danialj.rhhbmx, has your A51 kept working after you reported in your ticket that you had solved it? If so, could you tell us what setting you corrected?

Can someone please reply to my ticket that was opened regarding this same exact issue whenever it is found to have a solution? I have the Samsung A50 phone issue too and the newest UI update making Republic Wireless service not work correctly. The RW app is constantly crashing, Sim card notification about it not recognizing it, and can’t make messages/calls properly. I was told in my ticket to contact Samsung, but I have no warranty or anything like that, so they pingponged me back to RW since it seems to be a functionality issue with RW app and service specifically(The CDMA sim card), as all my other apps and features work on the device with the new UI update in place. I am having the same issues as stated above, and I may have to switch away from RW if it’s not fixed soon, it’s not making my job work possible for me unfortunately.

Edit: if it helps, I’ve tried all the troubleshooting mentioned above and then some. I’ve factory resetted many times in multiple ways, but there’s no way to “rollback” that particular UI update that broke it apparently.

Other than a factory reset, there is no other current fix. I’m surprised to hear that didn’t work. As the customers I’ve worked with in their tickets and chats have indicated that it did resolve the issue.

Other than that there are only two options. 1) Move to a GSM SIM as phones with the GSM SIM are not impacted. The earliest you could get one, even with overnight shipping, is Wednesday.

  1. Wait for Samsung to issue a fix, but there’s no idea when this will happen.

To be clear, you did a full factory reset, removing all of your info from the device are requiring to set the phone up overall from scratch like it is new?

Hi there,
Yep, I’ve completed multiple factory resets, removing all of my info from the device and requiring to set it up as a blank slate.

Thank you.

Edit: I’m going to submit to re-activate my old RW Moto X Pure phone for now until there is a potential fix.

Does your Moto X Pure still have its SIM in it? Do you know if it was a CDMA SIM? Because if it was you should be able to simply use the Republic App on the device to reactivate it.

Hi there,
Yep, I got it successfully activated and switched over to my old MotoX Pure phone, which still had its old CDMA sim. Back in normal operating business for now! No issues.


Yes, my problem has been resolved. My son helped me do a factory reset and spent a long time fixing it. Thank you!

1 Like

Thanks, @jennifers.lyg4dg.

Are there any updates or any other work arounds that have worked? My phone (A50) just updated 2 days ago and is now pretty much useless. I have been receiving repeated texts at least every minute for almost 48 hours now. I have done everything in this thread except a factory reset. After resetting cellular settings, it solved it for about 5 minutes and I received all of the texts sent to me in the last 2 days but then it went back to what is has been doing. My alarms are also not working and a few other apps have been crashing or not loading saying I have no internet/ service and my battery drains within a few hours when I am not even using it and gets really hot to the touch.

Basically it looks like the cell service cuts out about every 30 seconds (goes from showing bars to having a circle with a line through it then goes back to showing bars), sends me the same text again, and if I am trying to make a call, hangs up and says I don’t have service or that my SIM card is not in correctly. I opened a help ticket and was told it is a known problem, there is no solution or eta, and doing a factory reset might help. I don’t really want to go through the hassle of a factory reset for a maybe. I understand that RW doesn’t seem to know what the issue is but I don’t really want to be paying for a service I am not receiving and I can’t really go without a phone for an undetermined amount of time (especially that I can now see this has been an issue for over a week) so I’m hoping there might be something else I can try.

Hi @rachell.e4qfac,

To date, the only “solution” (and it hasn’t worked for everyone) is a factory reset.

So far, the experience has been limited to folks whose phones are provisioned for CDMA (legacy Sprint network) coverage. Republic also offers GSM (T-Mobile network) coverage. If you’d like us to examine whether switching provisioned coverage might be worthwhile, please share a zip code (nothing more).

I had to do a factory reset


I did used to have GSM, it works okay in my actual town but I get zero coverage in a few other places that I frequent

Good Morning @rachell.e4qfac,

Indeed, GSM (T-Mobile network) coverage once outside your immediate area (both to the east and to the west) doesn’t look good. The dilemma is other than a temporary switch to GSM while Republic works with Samsung to get this sorted, a factory reset is the only thing we’ve seen work (and admittedly some have reported that not working as well).

If despite the drawbacks, you’d be interested in a temporary switch to GSM, let us know and I’ll send some additional details via private message.

So I went ahead and did a factory reset last night and unfortunately it did not resolve the problem so I think I am going to need to do a temp switch to a GSM card.

Message an
Expert customer