Samsung a50 not working after android update 6/30/21

Hi @rachell.e4qfac,

To date, the only “solution” (and it hasn’t worked for everyone) is a factory reset.

So far, the experience has been limited to folks whose phones are provisioned for CDMA (legacy Sprint network) coverage. Republic also offers GSM (T-Mobile network) coverage. If you’d like us to examine whether switching provisioned coverage might be worthwhile, please share a zip code (nothing more).

I had to do a factory reset

97504

I did used to have GSM, it works okay in my actual town but I get zero coverage in a few other places that I frequent

Good Morning @rachell.e4qfac,

Indeed, GSM (T-Mobile network) coverage once outside your immediate area (both to the east and to the west) doesn’t look good. The dilemma is other than a temporary switch to GSM while Republic works with Samsung to get this sorted, a factory reset is the only thing we’ve seen work (and admittedly some have reported that not working as well).

If despite the drawbacks, you’d be interested in a temporary switch to GSM, let us know and I’ll send some additional details via private message.

So I went ahead and did a factory reset last night and unfortunately it did not resolve the problem so I think I am going to need to do a temp switch to a GSM card.

Hi @rachell.e4qfac,

I’ll get an order processed for that SIM card (no charge to you) this morning. I’ll send you a private message with additional details.

1 Like

Hello southpaw

Can you also process a GSM card for my account as well? I have tried the fixes above and nothing worked. Please let me know what else you need from me. Thank you.

Hi @michaelw.ew529n,

I’ll DM you to discuss coverage and get some additional details.

@bob7794 - were you able to get your phone working again with a factory reset?

@pseudoentity - have you been able to get your phone working, and if so, what steps did you take?

Hello,
No, I have not been able to get the Samsung A50 to work correctly after this update. I have since switched back to an older Moto X phone for now until I decide what I would like to do or if there is any progress on this issue.

Hi @pseudoentity,

Thanks,
I’ve also sent you another message by DM. Please let me know if you can’t find it.

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?


Issue Description

I updated the android this morning. After the update Samsung A50 will not make calls sometimes but not always says no sim found.

Hi @joeg.wgkz02,

I’ve moved your question into a topic on the same matter so we can focus the conversation in a single place.

We’ve seen different members solve this issue in different ways. Please try the following, stop when the problem is solved, and then tell us which thing solved it. (You don’t need to complete the list if the problem is solved before the list is completed.)

First, please make sure you’re on WiFi and in an area that normally has good cellular coverage.

  1. Reset the network settings by opening the phone dialer as if you were going to make a call, launching the numeric keypad, and dialing ##27263#. Tap the send button, and agree to any dialog boxes that appear. Did you get any errors about the 27263 sequence? If so, please use these steps instead: How to Reset Cellular Settings on Samsung Galaxy Phones with CDMA SIM Card – Republic Help

  2. If the problem persists after taking the steps above, then some people have seen it solved with a factory reset of the phone. (Read step 3, below, before you take action.) This will remove any apps you’ve added, remove any accounts you’ve added, and delete all your personal content (texts, photos, music, etc). How to Perform a Factory Reset on a Samsung Galaxy Phone via the Settings Menu – Republic Help Once you’ve done the factory reset, you’ll need to sign back into a your Google account and restore at least the Republic Wireless app in order to see if the phone is now functional.

  3. I’ve seen two people indicate that a new CDMA SIM card solved the issue for them. They had both done a factory reset before replacing the SIM card, but there’s no way to know if that was a factor. I’d be glad to try sending you a new CDMA SIM card so you can try this, but you’ll need to decide which is more important - the possibility of a quicker fix if the factory reset does the job, you could accomplish that today, or the possibility of a fix without needing to factory reset - in which case you’d want to wait for the SIM card. Some people find a factory reset to be the very last thing they’d ever want to do, and some people want to try whatever might be the fastest fix, so this will need to be your call.

I see that you also opened a Help Ticket and are working with one of our Experts on the matter. I don’t want to create a situation where you are trying things from both directions and make things worse, so please pick one conversation and focus on getting the help you need, there.

I have a factory reset. I also reset network settings as below. Including updating profile.Neither worked. The republic app shows my account and usage. I can receive a call to my number on wifi.

I can not call a number on wif or cell.

I could not update my profile under system updates setting. Says Internal error 111.

Does dialing ##873283# successfully update the profile or do you still receive the internal error code?

I does not seem to. I alos get a message that says to insert the service provider UICC then power on the device I havwe not idea what that means.

Universal Integrated Circuit Card (UICC) is another way of saying SIM card, which I presume is in the phone. You could try removing then reseating the SIM but we’ve not seen it solve this post update issue.

I understand the phone isn’t working for calls and text messages. Does it have cellular signal? If so, you might try updating the data profile with WiFi turned off.

1 Like

I have WIFI. Cell signal goes to little circle with bar in it at times. Cannot get internet or send text or call with cell only. With wifi then can still not make calls but can receive them to my number.

Yes, I understand the phone isn’t working properly. I’m suggesting you turn off WiFi, then try the profile update again, so that it attempts to complete over cell rather than WiFi. It may not work but there’s nothing to lose.

1 Like
Message an
Expert customer