Samsung a50 not working after android update 6/30/21

Joeg, I had all of the exact list of symptoms for 2 weeks. I’m guessing that you, like I did, have tried all of these suggested fixes in every imaginable combination. My wife and I have 2 identical A50s. In the end we ended up getting 2 new SIM cards which solved all the problems w/o another reset of any kind. Hope you get some peace.

Was the new sim card CDMA or GSM.

Somewhat fixed. I did do a factory reset earlier in the day. It did not work. I just tried uninstalling the Republic Wireless app the restarting the phone. Without reinstalling the app I am able to call other phones but the caller id is a different number than mine. When I do this it ring immediately.

I then reinstalled the Republic wireless app and tried to call others numbers. I takes a long time but does eventually ring the number called and I am able to talk to the other phone.
I am wondering if it is the Republic wireless app that is having a problem with the Android update.
When I turn off WIFI it does not work. Says no network connected.

They were CDMA, the same as our previous cards I believe. We don’t have a T-Mobile tower within 12 miles (GSM), and my phone gets no cell signal when set to GSM in the network setting.

You’re doing a great job of working through this very systematically. If I had gotten as far as you, my next step would be to refresh the Republic activation. How to Refresh the Republic Wireless Activation – Republic Help

1 Like

When I purchased the phone in early 2020 it came with a GSM card and I got no signal at home. The sent me a CDMA card and it has worked until this morning when i did the update. 7/12/2021.
That will be the next thing I try. Did you try reseating the existing sim cards.

I timed how long it takes when I place a call until it rings on three phones. It takes twenty seconds.
I also noticed there is an app called carrier hub. It says it reconciles problems with t mobile and sprint. Not sure if I have seen it before.

If I uninstall carrier hub and place a call it rings almost immediately and I can talk to other phones but the caller id has a different phone number. If I call that number back it rings my phone. If i disconnect WIFI it will not dial any number or receive calls.

Many times, with restart in-between and not.

Republic service does not work properly without the Republic app installed. The outbound Caller ID you see when making calls without Republic’s app installed is explained here: How to find your phone's secondary number and stop unwanted calls to that number. Ideally, Republic members need not be concerned about the secondary number.

To be certain I’m understanding correctly, with the Republic app installed the experience is as described and works when connected to WiFi but not when away from WiFi and on cell.

This is an interesting observation. Carrier Hub is a Sprint app. It’s getting some bad recent reviews at Google’s Play Store: https://play.google.com/store/apps/details?id=com.sprint.ms.smf.services.

There is a T-Mobile equivalent Carrier Hub Magenta not getting great recent reviews either: https://play.google.com/store/apps/details?id=com.tmobile.ms.smf.carrierhub.

I think but am not certain, the Carrier Hub apps exist to enable Sprint network activated phones to roam on T-Mobile’s LTE bands and vice versa.

Carrier Hub is a system app and cannot be completely uninstalled nor can it be disabled. The best one can do is uninstall updates.

Have you tried uninstalling the updates to Carrier Hub while leaving Republic’s app installed?

2 Likes

I tried to send you a private message via the email link you sent me but I am not sure if that is how to reach you. If you did not get the message would you please send me a private message to arrange getting a sim card. Thank you.

2 Likes

To those participating in this topic who:

  • are still experiencing the issue
    or
  • had the problem resolved by receiving a GSM SIM card, but prefer CDMA coverage
    or
  • thought the problem was resolved, but it came back

Our developers have come up with a potential workaround in the Republic app. If you’d be interested in testing this solution, please let me know.

@jennifers.lyg4dg, @bob7794, @donsvg, @pseudoentity, @rachell.e4qfac, @michaelw.ew529n

1 Like

Hi there,
I have closed my Republic Wireless account, you can remove me from this troubleshoot thread. It was a good run for 7 years of service! Hope a solution is found!

I would like to hear the work around for the Samsung A50 problem after the last update. Even though my phone says ringing/sent I can’t send or receive phone calls or texts. Please help me.

Bob

Hi Southpaw,
My phone seems to be back in the land of the living, and at this point I’m not sure what corrected it. It may be that simply sitting in a faulty state overnight, after reprogramming, did the trick; this seems to have happened before.
I am going to try GSM coverage when our 1st card arrives. Will installing a GSM SIM prevent my CDMA SIM that is currently working, from reactivating my phone if GSM doesn’t work?
While I’m waiting it sounds like a good idea to use the potential fix in case GSM isn’t useful. Both of our A50s were kaputsky Monday night.
I’m thinking the only result I can produce would be no further issues in CDMA operation, but am willing to use the fix for possible future insurance against another service drought.
Thanks again for your help, Don

Hi @bob7794,

I’ll be in touch with you by personal message in a few minutes.

@donsvg, I’ve taken over your Help Ticket and will reply to you there.

1 Like

My phone had a system update this morning and I’m having the same issues as above. The previous update did the same thing and not sure what made it start working again after about a half of the day with no service. Any advice or insights.

Hi @carlc.lpqcb6,

I’ll send a personal message for you with some instructions I believe will help.

Thanks I’ll take a look

I too am having this issue with my Samsung A50. I have tried factory reset, Network reset, VOIP reset. A factory reset seems to work temporarily. My most common way to fix this is to uninstall the republic app and reinstall. This seems to work however if I restart my phone it goes right back to saying that there is no sim card, the sim card in in the wrong slot or that a data connection could not be established. I have tried reseating the sim card, this sometimes works as well. I am on a CDMA Sim with Android 11. I am will to go back to GSM. I have decent coverage with GSM.

Message an
Expert customer