Samsung Galaxy S6


#1

I have a Samsung Galaxy S6. For some reason it is showing as not compatible. Could someone please help? Thanks!


#2

To be compatible it must be a Samsung Galaxy S6 with model number SM-G920T and have one of the following software builds:

MMB29K.G920TUES5DQB1
MMB29K.G920TUES5DQA1
MMB29K.G920TUES5DPL1
MMB29K.G920TUES5DPK1
MMB29K.G920TUES5DPI2
MMB29K.G920TUES4DPH2
MMB29K.G920TUEU4DPG2
MMB29K.G920TUES4DPF1
MMB29K.G920TUEU3DPD6

Please note: The T-Mobile branded version of this phone is not compatible with our service.

The previous information is taken from Republic Wireless Phones .


#3