Samsung phone not connecting to wifi

What phone do you have? Samsung Galaxy J7

What plan are you on? My Choice + 1GB

Does your plan include data, or just talk & text? Yes, 1 GB


Issue Description

The issue began this evening after I restarted my phone. I turn the Wi-Fi connection on but it turns back off and does not connect to my home network. When I turn it on, the Wi-Fi title grays out like it isn’t an option.

Hi @pamelas.eik0te and welcome back to the Member Community. Recommend the following –

  1. Try to forget the Wi-Fi network on the phone then connect to your WiFi again. Also check if the problem occurs on only a specific Wi-Fi network.

  2. Restart phone in safe mode to see if any 3rd party app is causing the problem. If the problem does not occur in safe mode then it is probably caused by an app. Even a recent update for an app that was working can cause the issue.

Here’s a link that lists some 3rd party apps that are known to cause issues –

Hope this helps. Others might have other troubleshooting steps and solutions too!

2 Likes

It doesn’t show me any networks to forget. It just spins like it’s looking for networks then turns back off.

@pamelas.eik0te – Don’t know if Samsung has anything different but on our Moto G6s you get to the forget network setting by the following –

Settings>Network & internet>WiFi>Saved networks - press the network you want to forget and select forget

or (short cut) Swipe down on notification bar>long press WiFi icon and WiFi window opens>scroll down to Saved networks - press the network you want to forget and select forget

See if either of these gets you to a spot where you can forget network.

Hi @pamelas.eik0te

I found an post online that might help. It has 3 suggestions starting with as @freddyp suggested, booting into safe mode.

The 2nd was to clear the system cache (Instruction in the article).

The 3rd was a factory reset. (I would hold off on that for now). :wink:

Hope this helps.

1 Like

I’m not seeing any networks. It’s almost like the phone can’t recognize a network anymore. Several network buttons in settings are grayed out.

Here is a link to No WiFi Networks Are Detected – Republic Help, just from a quick glance this may be something to try

1 Like

I tried that. It didn’t solve the problem. When I turn on wi-fi, it acts like it’s looking for networks but then turns off never showing any potential networks.

Hi @pamelas.eik0te,

It’s not entirely clear from your replies which of the suggestions you’ve been offered you’ve tried completely.

You mentioned this began when you rebooted the phone. Have you rebooted the phone again?

Are you able to turn Bluetooth?

I have tried everything suggested. And yes, I have restarted my phone again. Twice. Yes, the bluetooth is on and I am able to turn it on and off.

I have also begun getting a message that Republic has enabled the WiFi radio. I didn’t have that before and I don’t know what it means. I am not a tech savy person so this is difficult for me.

Thanks @pamelas.eik0te,

When you get the message that Republic has enabled the WiFi, it just means our app has turned on the phone’s WiFi for you. This typically happens any time the Republic app restarts, like after a reboot, if WiFi is turned off.
When you get that message does WiFi stay on, or does it remain in this grayed out state?

It’s starting to sound like a hardware failure, like the WiFi radio has been damaged. You may want to check with Samsung support for additional troubleshooting steps and to determine whether the phone is still in warranty.

Here is a link to a Help article for you How to Contact Samsung Support – Republic Help

I did a complete reboot and the wifi still won’t connect. I just bought the phone in March or April of last year but I’ve already ordered a new phone which should arrive tomorrow. I will definitely contact Samsung to see about warranty coverage though. I
appreciate all your help both with this issue and all the other times I see you helping others. It’s greatly appreciated.

1 Like

Thank you.

Message an
Expert customer