Scottathew's Journey to 5.0

(EDIT: My journey to activation is still underway. I’ll be post more thoughts and updates as things go along. I’ll also be providing a summary/conclusions/positives/negatives once all my lines are settled on a RW 5.0 plan.)

Activation… Or not quite yet…

So before I provide my feedback, please understand this. I’m trail-blazing. I’m hopping on the new plans knowing that there’s going to be pain. I’m providing this feedback so that others can know what to expect at this point in time and also so that Republic can know what’s good and bad. The intent isn’t to whine. The intent isn’t to ask for help. Republic is probably already aware of some of the issues and has them on a to-do list. The intent of this post is to provide intelligent, actionable feedback so that future RW activations go smoother.

So I attempted to active all four of my phones, taking them from two old Republic Accounts to two new Republic Accounts.

  • Activation failed
  • I called customer service, after a VERY SHORT wait time I was connected to a PERSON based in the US that fluently and clearly speaks my language, English
  • I’m told that I’m stuck in an “activation loop”
  • A ticket has been submitted to the “back office” and this is a known issue with activations currently, according to the representative
  • I have been able to insert my old SIM cards and I’m back up and running on all my phones
  • At some point when the activation is successful my old SIMs will stop working and I’ll need to swap them out
  • The service representative wasn’t able to give a time frame for activation, but she was very polite about it
  • I taught my 69 year old mother how to swap her SIM card out. She got to learn a new skill!

Constructive feedback:

  • The activation steps described are counter-intuitive
  • Having to enter “Apt” for the apartment line and “1” for the apartment is very odd (per the instructions)
  • After completing the activation steps the website says that it’s underway and should be done in a few minutes. However, this is false and no further feedback is given that the process has failed. When activation fails or does not complete within 15-30 minutes, an email should be generated saying what the next steps are
  • These are the instructions I’m complaining about: https://help.republicwireless.com/hc/en-us/articles/115005636388-How-to-Activate-a-Cell-Phone-or-SIM-Card
  • The phone rep said a ticket was opened for me and that an email would be generated for it, I have not received that email
  • The APN setup instructions are going to be IMPOSSIBLE for the target audience of “older folks” to follow. I would highly recommend that RW find some kind of way to automate it. I’m capable of following those instructions, but even for me, an IT systems engineer, it is a frustrating and error-prone process
  • The APN setup instruction field names do not match what my phone, which is on Android 12, has.
  • The APN setup field name orders are different from what is in my Android 12 phone
  • The APN setup instructions don’t accurately describe how to get to the appropriate menu to set that up on my Android 12 phone
  • These are the instructions I’m complaining about: https://help.republicwireless.com/hc/en-us/articles/4413675019543-Finish-Setting-Up-Your-Phone-s-APN-Settings

My phones are working on my old SIMs. Customer support is aware of my 5.0 activation problems. I’m fine for now :slight_smile:

Somewhere out there Republic Wireless staff are working some long, painful hours on a holiday weekend. To those folks, I say thank you. You’re appreciated.

8 Likes

Though my activation attempt was unsuccessful tonight, I second this sentiment. Most of the time, I don’t have any type of major issues with Republic Wireless service. Even when I do, I have a community of support to help me through the issue.

Republic Wireless, you’re appreciated! :slight_smile:

By the way, I think it’s a good general practice to have maybe at least 10 days of active service left before trying a port in or out of any carrier. Things sometimes happen, and ports might not go as smoothly as expected. I still am on the my choice plan with active service, and since my 5.0 SIM card arrived in the mail, I’m that much closer to having 5.0 service.

Were you trying to keep your numbers or get a new numbers on the 5.0 plans? If you were trying to keep your nubmers, it seems like you’ve gotten farther than me in this activation process.

1 Like

But…there has to be someone who has successfully activated a 5.0 plan, right?

Right.

Unfortunately, that would seem to be the majority of activations, RW members looking to move to 5.0 plan. This is very helpful, knowing what to expect at this time.

Correct, keeping our existing numbers. My situation is a little complex:

My old account:
Scottathew (going to 10GB RW5.0)
Daughterathew (going to 1GB RW5.0)
My mom’s old account:
Momathew (going to 10GB RW 5.0)
Dadathew (going to 1GB RW 5.0)

New Account 1 (10GB):
Scottathew
Momathew
New Account 2 (1GB):
Daughterathew
Dadathew

It’s not just current subscribers updating to 5.0. I moved in from another carrier, tried to move my number, had my current provider cancel in minutes, and 8 hours later, found out that there is a major activation problem. In the meantime, I have no cell service for, presumably, the next three days. No one should activate a new 5.0 plan until Republic announces that these problems have been solved. Otherwise, you could end up in the lurch.

3 Likes

Follow-up on my RW 5.0 activation attempt for four lines:

I’m still not activated (however, zero business hours have passed since my last post due to the holiday). I am running into an interesting issue. One of the numbers I’m trying to port over (from RW 4.0) has a port-out pin that I cannot set. The issue seems to be that the number is owned by two different RW 4.0 accounts, both of which I control. However, in one of the accounts when I click the button to change the port-out pin, it does nothing. The text boxes to enter the new PIN never show up. My dad has a ticket opened up for it, Ticket #2200400.

Another thing to note in the realm of feedback. One of the four numbers I was trying to move to RW 5.0 apparently didn’t have the correct port-out pin. The error generated was sent to the old account’s email only, not the new account. In this case, the email went to my dad’s email. He doesn’t check his email. It would be nice if an email was generated to the old account’s email AND the new account’s email.

Once again folks, keep in mind that this is a holiday weekend. These are all problems that I hope RW starts chipping away at on Monday. RW has had no opportunity to address my issues yet. I’m hoping for movement in the coming days.

2 Likes

I made a more in-depth post here: Welcome to the New Republic Wireless: Better Plans, Better Service, Better Support - #492

In summary:

  • I tried to activate four lines
  • Got through the website successfully, stating my phones should activate shortly (using Google Chrome, I didn’t try any other browser)
  • The phones never activated
  • Contacted support, they confirmed a bug and opened a ticket with the “back office”
  • I’m back up and running on my old SIMs awaiting the new ones to activate
1 Like

I’ve got one for you now! On the evening of 12/23 I started the activation process for four RW 4.0 going to RW 5.0. At 3:19am this morning one of my four lines has activated and I was able to place a successful non-wifi phone call with the RW 5.0 SIM in it.

The other three phones have still not switched over to the new service but are still functional on the RW 4.0 SIMs. Hopefully I’ll get some movement on the rest of the lines today!

5 Likes

For my edification, what was the process? Was it an email saying “Welcome to Republic”? What should I be looking for?

Yeah… More feedback for Republic on that…
My experience as an RW 4.0 to 5.0 customer was that I received an email to my OLD account saying that my service line was canceled. Ideally an email should have been generated to the NEW account email saying that the port was successful.

In the future when RW gets things all fixed up the customer would activate on the web and the activation would immediately go through, as the website states, and an email wouldn’t be necessary.

Here’s the email I got to my old RW 4.0 account email:

From the for what it’s worth department, you’re receiving the same notice of cancellation to your old account’s email address any customer gets when porting their number out. I understand you went from 4.0 to 5.0 but just like porting out of Republic altogether, doing so involves a port from one carrier to another (in this case Bandwidth to AT&T). Previously, moving a Republic number from one phone to another did not involve a change of carrier.

Given existing Republic numbers are wireline, I’m uncertain the port and, therefore, activation will go through immediately. But, I am hopeful the coming more elegant process does a better job of communicating status.

1 Like

So, once you got that email, you restarted the phone, and it was active? Since I’m coming from another carrier, I can’t rely on the cancellation email.

Correct, I got that email, noticed the phone stopped working, swapped out the RW4.0 for the RW5.0 SIM, rebooted, and it worked immediately. Tested a phone call off of WiFi.

Bonus, this phone was a Moto G5 Plus which I don’t think was officially supported, but I rolled the dice because the phone does support VoLTE. This will enable me to hold out upgrading my phone until the Pixel 6a comes out later this year.

3 Likes

For what it’s worth, this is not the process recommended by RW’s help page: Insert SIM, enter info (including port setup), and wait for email. I followed the process, and the port has gotten stuck between cancelling the number with my old carrier and picking it up on Republic. Once everything is running smoothly again, looks like the process might need to be revisited.

Good for you that you’re working now! I’m curious, what did you do for the APN setups for AT&T detailed here?

Multiple people (including me) have noted that we could not add APNs #2 & 3 in those instructions. I’m wondering if you added #1 & 4, or only went with what came up by default on the new SIM (which for me was different from these instructions entirely).

Do you have a Pixel by chance? I’m seeing the same lack of ability to add the second and third set of APNs. on both a Pixel 4 XL and a Pixel 2 XL. In limited testing with an active 5.0 SIM, that which is supposed to work seems to do so with just the first and fourth set of APNs.

I’ve flagged the help article for correction but that may take some time.

1 Like

Yes, Pixel 3a running Android 11 with an IMEI starting 359677.

This phone I think was originally on RW (probably 4.0) up until a couple of years ago when I moved it to Tello first and then Mint Mobile, from where I’m now porting it. The port cancelled the service at Mint within hours (or less) of requesting the port and now I’m stuck in limbo with no service (except limited SMS over wifi only, somehow), a very un-fun place to be!

In limited testing with an active 5.0 SIM, that which is supposed to work seems to do so with just the first and fourth set of APNs.

Do you mean by this that it’s your opinion on these Pixels maybe we only need to add APNs #1 & 4 and once activation completes, that configuration should be sufficient for all features to work?

1 Like