Screen background keeps reverting back to default

Moto G5 Plus running Android 8.1.0

My Choice 1 gig

Includes data/text.


Issue Description

A couple of months ago there was a phone update, and ever since then the rotating background option for the wallpaper has been failing. I am glad its not a critical issue, but it is annoying as it could happen a couple of times a day. I set it, come back a few hours later and its back to the default. Anyone else having this issue?

Hi @shaunb,

I’m not familiar with the rotating background option. Could you give us the exact steps you’re taking to set your preference?

No problem.

  1. From your homescreen tap/hold down on the desktop background. Three options will show up at the bottom of the screen, tap “Wallpapers”.

  2. From there a white screen will show up with Live Wallpapers, select “Rotating Image Wallpaper”.

  3. At the top right, tap “Set Wallpaper”.

  4. Now the options show up to set the wallpaper for either the home screen or the home screen and lock screen. It fails for me on both, so just select Home screen.

Now, when you exit out to your desktop you should see a nice looking background image (golden gate bridge, flowers, etc). So I just reset it again to live wallpaper at 12:30pm, I’ll update this in an hour or so when it defaults back to the boring wallpaper.

Hi @shaunb

Is it possible you have a Launcher installed that is in conflict with the wallpaper settings?

You may want to try clearing the cache of the “Live Wallpaper Picker” app
You can locate it by going to
Settings -> Apps -> 3 vertical dots -> Show System
and then locate “Live Wallpaper Picker” in the list

Maybe? The only launcher I see listed, in the App Info/All Apps//Show System is “Launcher3”.

I just tried clearing the cache - and will post back here if the wallpaper defaults back again. Thank you all for the suggestions.

1 Like

Good news! Since clearing the cache the background has not switched back to default. Fingers crossed that it stays that way.

4 Likes

Thanks for reporting back on this. Good luck!

Ok - today it reverted back to default again. On the positive side 7+ days of it working is much better than just a few hours!

Sorry to hear that…another cache clearing help…or is it behaving different this time around?

It has to do with the whole rotating background option. If you select a static background image it doesn’t have an issue. Watercolor watermark it is then…:slight_smile:

Thanks for reporting back your experience. Not entirely sure why a static background works… it likely is the system app that creates the transition that might be buggy.
I will keep an eye out for any other tips/tricks I might come across and suggest here if I find anything useful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer