Sending... Not sent. Tap to try again

texting

#1

Enough is enough! I’m sick of the fact that text messages aren’t being reliably sent and received, or sent and received too late, or they get duplicated at the receiver’s end! I’ve missed many important text messages and some of my important text messages have arrived late. I have no reliable way of knowing that a text message I send will get to its destination, nor that I might have missed a text message that was sent to me. There is no pattern to it – it happens randomly and both on WiFi and Cellular networks. I have 4 users on my account all of whom report the same issue. This ongoing Republic Wireless issue has caused me a great deal of headache and problems at work! Due to the nature of my job, I am subscribed to various notifications and I have missed many of them!!! I had to switch to using Google Voice for text messages in order to ensure reliability.

I have tried the solution here many times: Error "Not Sent. Tap to Try Again." When Sending Texts – Republic Help However, it is only a temporary fix! The issue eventually comes back.

I have been a Republic Wireless user for 6 years, since version 1.0, which did not have this issue.

I’m seriously considering switching myself and my family to another provider as I see no end to this issue. I’m paying for the service which does not reliably work. I would rather pay more and not have to worry about it. I think Republic Wireless should issue partial refunds every month to those users that have experienced the issue that month. I have recommended Republic Wireless to many of my friends before (and a dozen of them have joined Republic Wireless since), however, I am no longer recommending it. This is simply ridiculous that we have to experience this issue in this day and age!


#2

In the Help Doc you referenced, did you meet the requirements listed under ‘Environment’?


#3

Both Apps
Moto G 3rd.


#4

Have you worked through the support process by Opening a Ticket?

  • Often they can check to see where the message failed by reviewing the point of origin and time in the back end

#5

Do I have to do that every time a text fails to send?


#6

My G6 was doing this last night, but it was a first for me. I’ve got both Anywhere and Messages on my phone, and found that switching between the two fixed it for me. Generally I use Messages as my default texting app, and after rolling back updates and re-updating without a solution, I made Anywhere my default. All of a sudden I could send and receive messages again, though I didn’t get the ones I had missed in the interim. I switched back to Messages and it’s been working fine since then. I don’t know if it’ll work for you, but try toggling the default setting and see if that sets things right.


#7

If you can identify a failure and report it via your ticket within a reasonably short period of time they should be able to use the to/from numbers and failure time to initiate the review.


#8

The issue happened today again. I have just submitted a ticket. My family will leave RW if this issue isn’t resolved soon, once and for all.


#9

Sorry you’re having so much trouble with texting. Have you cleared the System Cache?

This will not delete personal information, but it will take up to 20 minutes to complete. It’s a good idea to do this every few months on these older legacy phones, to keep them running smoothly.


#10

Don’t think it is republic wireless, I also have the same issue on another Sprint network. I think Sprint is getting really crowded and service is really bad especially when you are in a giant metropolitan area like Southern California. But I will take the clear cache advise and give it a try. I highly doubt it would do the job though.


#11

What app are you currently using with your phones for texting?


#12

default Android messaging app. Highly doubt it is app specific. I also recall my friend who is on another Sprint network (boost) saying the same thing to me when he sent me some texts and I told him I didnt receive them. I have also experience the same issue where I sent text out but the recipient (again Sprint network) didnt get them.
Now this scenario doesnt happen often but when it does happen it is super annoying and we all know how bad communication can lead to misunderstanding.


#13

What model phone? The default Android messaging app on the older phones (Moto X1, X2, G1, G3, E1 and E2) hasn’t been updated by Google in quite a while and works poorly on Republic and other carriers. If that’s what you’re using you should load the new Google Messages and you’ll likely find the problems are gone.


#14

Hi @wimpog,

I’d like to address some of the concerns in your topic.

First, you mention that you’ve been a member since 1.0 which did not have these “Not Sent. Tap to Try Again” errors. The phone you’ve named - Moto G3 is a 1.0 phone. If you think there’s a substantial difference in how the service works between 1.0 and 2.0 it might be worth moving one of your phones to 1.0 to see if the error is consistently resolved.

That the issue comes back tells us that the cause is still there. So we need to think together, like detectives, to figure out what the cause may be. While your frustration is understandable, the facts that you have been with us a long time, have referred many people to us, and are considering switching don’t help us figure out the cause of the issue.

If the problem is consistently coming back on all four phones, think about what all four of them have in common.

  • Are they all Moto G3’s on 2.0?
  • What apps do they have in common? Do you have an anti-virus, performance boosting, battery enhancing, or memory–cleaning apps on these phones?
  • What area are they all in? If they spend an extended amount of time in an area without cellular service, the steps in that help article may be required to refresh the connectivity.
  • What is the service state when this happens? You mentioned that it randomly happens on and off Wi-Fi, but sometimes what seems “random” isn’t, once it’s closely studied. My phone did this same “not sent, tap to try again” thing this morning, but when I closely examined the phone, I noticed I had absolutely no cell service. I toggled airplane mode a time or two, but eventually just had to wait for it to come back. I think it may have been a temporary tower outage or overload. Are you in an urban area with a high population density?

Our Community will be glad to work through this with you and see if pinpointing a cause can lead to a solution, however, you also mentioned:

and if that’s truly the point you’ve reached, there won’t be much our Community or our staff can do for you.


#15

I have had the same problems. In fact, I got into a HUGE fight with an EX Girlfriend because I accused her of not responding to my text. A YEAR LATER, I met a beautiful woman at a restaurant, but my phone was in the car, so when I ASKED HER OUT, she said yes and sent me a text message. In fact, I sent me the text message from HER PHONE, but I NEVER got that message and NEVER saw the girt again. In sum:

  1. Fight with Ex Girlfriend because of missing text message.
  2. Missed opportunity to date a beautiful woman because of missing text message.
  3. I’m still single and lonely partly because of missing text messages.

I’m using a Samsung Galaxy S7U Edge. I’m using Messages (Google?Android?)


#16

You may be correct about the network being crowded, but when this issue happens over WiFi too, then it’s not a network issue. Have you tried using either Anywhere app or Google’s Messages app?

Google Messages:


#17

Why are there only two of us with this problem? I just cleared my cache. Hoping that does it.


#18

Believe me it’s not just two people this happens to. I’ve had the issue on occasion. Sometimes there is an outage with Republic Wireless and sometimes there is an issue with the local carrier tower. If the phone doesn’t have sufficient wiggle room in the system cache that too can cause this problem. Having too many unsent texts can essentially clog up the app. Also saving too may texts can cause issues too. If you’re not in the habit of deleting texts and the app isn’t set to automatically delete it it can cause issues too.

There are a lot of different reasons for this to happen, that’s why we all have different suggestions. Hopefully one of them will work for you!

I backup my text and call history to Drive using this app, then I delete them from the phone. If for some reason I need to reference back to a particular text, I can restore it from Drive using the same app:


#19

Yes, it’s more than 2 people. The rest of us are just too frustrated to keep bringing it up. It happens to me, too, quite regularly. I’ve just come to the point that I can’t rely upon technology any longer.


#20

Well, I’ve cleared my cache a few days ago, so it is not happening yet. I’ll post back here if it happens again.