Setting up 2 phones one new one old


#1

I am setting up my new G5. Gave my moto x 2nd to my hubby after a factory re-set. Can’t make calls on either one. Message says: It says “this phone isn’t configured to make calls” and when I click “Change Configuration” it goes to the setting page. What am I doing wrong?


#2

Moto G5:

Is the SIM card installed?

Is the Republic Wireless app installed/up to date?

Have you checked here for step by step instructions:

https://republicwireless.com/activate/

Moto X2:

You will need to update, PRL and Profile, it’s best to be connected to WiFi when doing this:

Settings
System Update
Tap on Update PRL

When completed go back to System Update
Tap on Update Profile

When finished restart phone

Go go Google Play Store
Update Republic Wireless app
Install Telephony app

After both apps are updated/installed restart the phone. Test the phone.


#3

G5
I am technically challenged. Everything is updated on the G5. Updated the RW app earlier and chose a plan. I am connected to WIFI on both phones. The only thing that is not working is the phone. I am used to using the motox 2nd, had it 4 years. I followed the directions on the phone when setting it up


#4

G5 Play. How do I get past the Grant permissions screen?


#5

Do you see the button to agree to the permissions? I’m going by memory here, you may need to scroll down to get to that button.


#6

Yes and when I click on grant permissions it goes to the setting page


#7

Ok, on the Settings page do you see where it says Republic Wireless? Next to that there should be what looks like a little switch, you need to tap on that switch to turn on that permission.


#8

on the Setting page there is notRepublic wireless. I tried again after restarting the phone and I still get Change Configuration and when I click on that it goes to grant permission and when I tap on that it goes to settings but no Republic Wireless


#9

On the Settings screen what does it say? If I remember correctly I had to turn on Data. Is that what you’re seeing?


#10


Ok So here is a screen shot


#11

I see. You should be able to scroll down to grant permissions.


#12

When I click on grant permissions it goes to settings


#13

Please go to Apps, find the Republic Wireless app, tap on it. Tap on Permissions and check that all the switches are turned on. If this doesn’t get you past that screen, restart the phone.


#14

Is anyone here?


#15

If I understand this correctly. You want your number from your Moto X2 to go to your Moto G5? When you set up the Moto G5 you chose to have the number moved to the new phone, correct?

Did you receive an email from Republic Wireless that the transfer of the number was completed?

Once you receive that email, your Moto X2 will be deactivated. You can either do a factory reset on the phone or when you reactive the phone, this time pick the option to choose a new number.


#16

Yes Moto x2 to to G5. I transferred his number from motox 1st to the Moto x2.

No email from RW. Should I have gotten an email from them? I did factory reset on the moto X 1st


#17

The email went to my gmail account and I never check that email saying it was set up. But they changed my phone number! My phone is a business phone!


#18

It can take up to an hour for a phone to activate. You should get an email confirming that your phone is activated. You may need to restart the G5 to see if you can get past the Permissions screen.

Once Moto X2 is deactivate then you can proceed with activating that phone with a new number.


#19

OMGosh, they changed my phone number. How do I contact RW directly?


#20

You can open a ticket using this link:

https://republicwireless.com/help-center/

Once you open the ticket, please post the ticket number here.