"Sign into network"


#1

I am wondering if anyone else is having this issue. I have a Nexus 6P and I am on the $15/mo talk/text plan. This issue only started happening when I upgraded to Android 7.1.1.

Every time I connect to cell, I get an Android system message asking me to “sign in to network.” (See attachment) It is also accompanied by a little ‘x’ on my cell signal meter.

I can still receive calls and texts over cell, but sometimes MMS don’t send or receive. It happens even when I have strong cell signal.

I upgraded my plan to the 1 GB data plan for testing, and the Android system message went away until I reverted to the no data plan, and it came back.

I know it is not a problem that can be solved by reinstalling the RW app, or clearing the cache, because I clean installed Android 7.1.1 from the files provided by Google by flashing via fastboot: 3 times with two different downloads of the files verified with the SHA-256 checksum both times. They were good downloads. I was able to recreate this error after each clean install. It also popped up when I tried it on two different custom ROMS based on Android 7.1.1.

I did file a ticket with RW, but after having 4 different support people take turns replying to the same ticket, all telling me to try fixes like reinstalling the RW app and clearing the cache (after I had told them multiple times I had reinstalled the whole blasted OS, which includes whole new system and cache partitions) I gave up and asked them to close the ticket. (To be fair, one guy tried to duplicate the issue on the lab Nexus 6p, but was unable to recreate it. He was the one guy I felt actually read what I wrote and tried to help.)

Has anyone else seen a problem like this, or am I actually really special like Barney always told me?


#2

I believe it may be a result of one of the Google services not being able to reach a server, but I’m unsure of why it is happening.

Edit: I’ve also seen reports of this happening when an SMS/MMS can’t find a data path. Do you have Google Messenger set as your default messaging app?


#3

Yes. I followed RW app’s instructions for setting up my phone. I could also add that this happened when I traveled over the holidays. I’ve seen it happen in MI, IN, IL and WI.

If it is a google service not being able to reach google servers, why did it not show up on Android 6.0, or Android 7.0? Why only on 7.1.1?


#4

The “sign in to network” message itself pre-dates KitKat. I don’t know why it’s showing up on your phone now. You might ask in the Google Groups: Nexus Help Forum.


#5

One other question. The “x” over the signal meter indicates that cellular data is disabled. Did you perhaps disable cellular data in your Android settings? With Republic Wireless, you need to leave data turned on in the Android settings even if you have no data plan. If it is turned on and the “x” is still there, I would point the finger towards the Republic Wireless app not behaving well with 7.1.1. There was a warning with 7.0 that using data saver would not play well with the app (Android Nougat Now Available for Nexus Phones ). I’ll admit I’m fishing a bit here, but in the absence of any other help, why not?


#6

In this case, it does not mean that. I get the ‘x’ all the time on cell. I never turn data off because I know it’s needed for RW to operate properly.

Also, when I turn data saver on, the warning you mentioned does pop up and it prompts me to allow unrestricted data for the RW app. I have the unrestricted data enabled, but it still does not resolve.

I think it is interesting that when I upgraded my plan for a few days, it went away (the ‘x’ too) but came back as soon as my billing cycle reset and my plan switched back over to just talk/text.

I agree that it is the RW app not playing nicely with 7.1.1. I am hoping that if I raise enough noise, RW will finally take notice and realize I’m not just experiencing user-error . That’s why I’m asking if anyone else is having the problem.

.

Thanks for the suggestions! I appreciate it.


#7

Reporting back: I went to the Google Nexus Forums and did some poking around. Others have mentioned similar problems and the suggestion was to call the underlying cell carrier.

So, I called and talked to a very very nice guy who told me that I had tried everything that he would have suggested and he said that it seems like I know what I’m doing (RW help, take note of this: we’re not all idiots.)

We talked through the issue, and he said as far as he knew there was nothing he could do from that end. But his suggestion was that perhaps it was an issue with RW app trying to establish a data connection for VoLTE ( is that what Bonded Calling uses?) and/or other services for which RW uses data on a plan that doesn’t have data ($15/talk and text plan). He thought maybe the RW app doesn’t play nicely with the new Android 7.1.1 upgrade when it comes to using data for phone calls.

Anybody want to weigh in? Any thoughts or ideas are welcome.


#8

I have had the same problem w/ my wife’s Nexus 5X on Republic. I believe it is a problem with Android 7.1.1 as it only started showing up after the update (same as you).

This is after a complete Factory Reset, cache wipe, Republic app uninstall/reinstall, switched SIM cards, reactivated, the works.

It is indeed something not playing nice between Republic and 7.1.1 without a doubt and there is nothing as a user that can be done.

The ball’s in your court Republic.


#9

Good news! I got an email from a Tier 3 team member. He was able to reproduce the error on his 6p running 7.1.1! He’s forwarding it to the engineers to get a fix. Thanks Republic!


#10

Any word on getting this resolved? Since you heard from them is it still happening to you? Absolutely everything you stated is still happening on my phone, 6P also. I was going to file a ticket but don’t see the sense in replicating all the conversations and work you’ve already been through. This is driving me crazy!


#11

I haven’t gotten anything back yet.

However, I jumped ship to Fi for what I hope will be a short amount of time because I really do like RW. I’m paying a bit more (keeping mobile data switched off, so I should get a $10 refund at the end of each month) but I get no goofy messages, I get full bars of Sprint at my house and around my town (which now that I think of it, it’s kind of silly to pay for a cell phone service with no cell coverage. . . :confused: Thanks Tmo) I get all my phone calls even when I turn on Airplane mode with wifi on, and no RW app waking my phone up every hour, so my battery is draining .18%/hr at night with cell radio on! That’s 1% every 5 hours of standby. Crazy!

But even so, even using no data at all, Fi comes out to $60/yr more that RW. That’s one week’s worth of groceries to feed my family. If Republic Wireless could get these bugs worked out and Sprint coverage back, I’d switch back in heartbeat!


#12

Ok i made an account on here just because i wanted to share me solution an older friend of mine had this exact problem on his ans phone < a brand from India basic.android smartphone> any way i tried everything you did nothing worked then i tried two more things you havent mentioned the first one is i went to settings_about phone i first updated his profile and i took notice that it said network data connected but the pesky x on the 4g wouldnt leave. so i updated his phones profile and ohm. it said activating phone for data.usage. then it said configuring phone for data and talk. BOOM the internet worked flawless. and it stayed that.way for almost a.month then the x came back and this.time …nothin and in the notifications it kept saying connect to carriers network but wouldnt open the site so i again tried.something i had not seen mentioned its the programmers network reset+activate+connect. its the only way.to actually connect to your carriers network if your kicked off this is how you do it

company network reset

before i write the tutorial i need to say a six digit code is needed for this depending on company. try this code .first if nothing happens lmk i can get you the right one.

  1. open up your dialpad to make call dail ##72786#
    and hit call.

  2. the phone will then say warning doing this will reset your connection and internet service settings.are you sure? hit yes( incase your wondering like i was my friend didnt loose any data. infact his data cap is unlimited bit it shows the data for the month reset only not the billing info or anything if he had a data plan it would have gave him a free refill of data.)

  3. the phone will shutdown and reset itself when it powers back on you will have to click through it. now the.other should be working 4g perfect if not update the profile, prl,ohm,and check for firmware updates. you will be successfully connected. t5nb5


#13

Hmmm… Not sure how relevant this is.

#1 I haven’t had the issue anymore. They must have gotten it fixed.

#2 Your fix wouldn’t help my situation after I nuked my phone anyway. And by nuked, I mean used Command Prompt with it hooked up to my PC to wipe EVERYTHING, including the OS and call settings, and internet connection settings, and carrier settings. Even activation on RW. Nothing left on the phone. Clean slate. Nuked. Then I reinstalled using the factory images downloaded from Google. What I’m saying is there was nothing left to reset.

I mean, if it worked for you, great. I’m glad you’re up and running. But since this was an issue that RW identified and fixed with an update (read this whole thread; it doesn’t take very long), I’m not sure anything on our end is really needed.

Have a good one!