Signal app is eating all my data



Hi - I am using Signal for video calls and texts to other Signal users (it’s not my default MMS/phone) . I’m not using it that much but it is eating up all my data, as in 1gb last night when I wasn’t even using it. Are there any settings I can change so that Signal is only used when on wifi? I just deleted Signal off my desktop - maybe it was syncing and eating up my data, even tho I was on wifi.

I am guessing it switches automatically to data when the wifi connection slows?

Please let me know if you have any ideas. I really like Signal because of the encryption but if I can’t figure out how to make it stop eating all my data then I guess I’ll have to delete it.

By the way, if it makes a difference, I do have Google play services installed and I do use Google voice for calls and texts.


Hi @karag,

Apps can use data to access the Internet when running in the background and not being actively used. Signal’s app on your phone would access the Internet to sync with its desktop counterpart. Even though the desktop is on WiFi, it’s possible your phone might have dropped the WiFi connection causing Signal to use cell data.

You might try enabling Android’s built in Data saver option, which is designed to keep apps from connecting to the Internet (and, therefore, using data) when not being actively used in the foreground. More on Data saver from Republic is here: How to Enable Data Saver – Republic Help.

Alternatively, you could use a local firewall app on the phone to restrict individual apps access to cell data. This one is popular:


Rolandh, not sure I understand this app. How long before it decides an app is not accessing Internet, and cuts off access?
My G6, I just noticed the other day, will cut off WiFi and use cell when inactive, like when I go to bed. When I get up, it goes back to WiFi. I think the new OS the Google/Alphabet put out makes phones work this way, and by deduction, any apps running in background will go out. I guess you can use this, but I would rather just go into settings and end app running in background.