SIM card not recognized after international travel

Moto G4 Plus XT1625
Android 7.0
Build # NPJS25.93-15.7-8


1.5 years ago I traveled to Israel and used an Israeli SIM card. When I got home and tried to use my old RW SIM card, it wasn’t recognized. Support said they would send a new SIM card, but never did. I ended up using another phone, but the battery died. So I want to use my old phone. The SIM card I have in my battery-dead phone is Nano, and I need a micro for my old phone. I ordered a RW SIM card at Amazon. I inserted it, but once again the SIM card isn’t recognized. I tried turning off and on. I tried restarting with the POWER/VOLUME HIGH button. No help. I tried toggling Airport mode. Nope. I took the SIM card out and reinserted several times. Nada.

Help!

Thanks!

Hi @ericas.ttoppm,

This is a bit of an odd one since merely using an international SIM shouldn’t cause a factory unlocked phone to not see other SIMs. There is the remote possibility the Israeli SIM somehow locked the phone to that network.

Is the Republic app still on the Moto G4 Plus? If so, please try updating the Republic app to be see if that helps. If the Republic app was deleted or disabled, you’ll need to reinstall or enable it.

Please let us know if that helps or not?

I updated the Republic App and rebooted. Same problem. SIM card not recognized. RW app opens and says the phone is supported and provides a link to purchase a RW SIM card.

Hi @ericas.ttoppm,

I’m sorry the team failed to send that SIM card a year and a half ago. I’ve reviewed that ticket and it looks like one agent indicated he had sent it, but just never did.

The Moto G4+ was always a bit difficult when it came to the SIM card reader. We even have a help article specifically for it:


One of our technicians mastered the art of using the “micro” adapter to offset the “nano” SIM card just a little to make it lie really flush in the SIM card tray. You might try playing with that a bit to see if you have any better luck.

Where did you get that Android build? I don’t come up with anything when I search for it. Sometimes using a particular SIM card can invoke an Android update that is specific to the carrier. I’m wondering if perhaps your phone was updated with a build specific to the international carrier and that build is ignoring anything other than that type of SIM card.

There’s also the chance that the SIM card reader has been damaged and simply cannot recognize a SIM card anymore.

1 Like

So, what should I try? The SIM card sure seems to fit perfectly. The build? I don’t know - I update it when it tells me to! Can I force a different build? I can do a factory reset - everything is old on the phone anyway. Seems like too much of a coincidence to happen right after being used internationally.

One of the community RW expert members tried to help me. RWEXP18. But nothing worked.

I put tape on the non-contact side and played around with it and got it to work

5 Likes

Probably not. Your build is newer than the last build we have record of.

A factory reset would not change the build.

What I was describing would be a situation where the update happened while you had the international SIM installed, but the effect of it would not have been noticed until you installed a different SIM card.

Thanks for letting us know what fixed it for you!

1 Like

Happy to see you got the Sim card issue resolved. Also wanted to let you know that the G4PLUS has the system update to Oreo 8.1 and security update to December 2018. You can check on this by opening settings, then system and tap on System updates.
The below picture is from my G4PLUS. Unless you have the G4?

Thanks @grandbobby, I missed that when I looked over our list.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer