Slow upload speed and erratic download speed

What phone do you have? Motorola G7 Power

What plan are you on? 1GB Data Plan

Does your plan include data, or just talk & text? All


Issue Description

Tried to restart both phone and router. Phone speed is erratic . Downloads are good and then slow. Uploads are very slow. Under 1 MB .

Hi @donalde - you might want to have a look at this How to article - How to Set up a WiFi Router to Work Best with Republic Wireless' Service – Republic Help

Step 2 in the procedure for Router tweaks is very helpful. We have a dual band router and connect our Moto G6s to the 5GHz band due to interference on the more common 2.4GHz. I mention this just in case you are connecting on 2.4GHz and might also be experiencing local interference.

See if any of this helps. Come back with any questions. There are some sharp Community Members that might have other suggestions.

1 Like

@donalde,
There are many factors that contribute to the problem you are experiencing. Router Tweaks - Keep WiFi 1st - a Community Guide has been created from user experiences/problems and provides some information that may help.

  • I would suggest you take a look at this and then provide a screenshot of the results of Quick Check #2, plus let us know what make/model router you have
  • ETA what speed does your ISP provide/charge you for?
    • Run Speedtest.net (select Single connection) for a more accurate speedtest on cellphones, the other tries to saturate the link by starting multiple threads/connection

Hi @donalde,

Are these slow speeds using WiFi or cell data?
Upload speeds will always be much slower than downloads.
If you are concerned about the data speeds in my experience the RW GSM provider has higher speeds.

:flight_departure:

It actually ended up being an issue with the internet provider Spectrum They didn’t even acknowledge there was a problem until 2 hours after a couple of attempts by their award winning customer tech support.

Thanks for the feedback, here is a Help Article based off of an incident another user faced, through a lot of work with the community and Republic Help team it was eventually fixed

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer