SMS: code leaking on Republic Anywhere: no text messages on Google Messenger

Samsung Galaxy S7 Edge 3.0 plan with Google Messages
iPhone 6 with Republic Anywhere


Issue Description

Suddenly today on my iPhone (work phone), Republic Anywhere started giving me a bunch of code instead of text messages. See below for an example of what I’m seeing. Restarted. Same. Deleted and reinstalled app. Same. I can decipher the intended message but it is a pain.

So I switched to my Samsung/Republic phone and was not getting messages at all via Google Messenges.

Both phones and apps have always been solid for me until today. Suddenly it is a mess. Had to make people use my Google Voice number for text message in order to carry on any kind of conversation.

Below is an example of what a text looks like via Anywhere. (All phone numbers have been redacted – including a phone number that I don’t recognize but assume is some kind of background/system/alias number used by Sprint or TMobile or some such to get the info to my phone’s number).

{"from":"+1914redacted","to":["redacted","redacted"],"text":[{"content":"Okay","name":"text000001.txt"}],"smil":[{"content":"\u003csmil\u003e\u003chead\u003e\u003clayout\u003e\u003croot-layout/\u003e\u003cregion id\u003d"Text" top\u003d"0" left\u003d"0" height\u003d"100%" width\u003d"100%"/\u003e\u003c/layout\u003e\u003c/head\u003e\u003cbody\u003e\u003cpar dur\u003d"5000ms"\u003e\u003ctext src\u003d"text000001.txt" region\u003d"Text" /\u003e\u003c/par\u003e\u003c/body\u003e\u003c/smil\u003e","name":"smil.xml"}],"date":redacted,"i":"9a118fc9-c617-4ec5-9718-929c133c1f44"

header for the text in unicode

{“from”:"+1914redacted",“to”:[“redacted”,“redacted”],“text”:[{“content”:“Okay”,“name”:“text000001.txt”}],“smil”:[{“content”:"<region id=";Text"; top=";0"; left=";0"; height=";100%"; width=";100%";/><par dur=";5000ms";><text src=";text000001.txt"; region=";Text"; />",“name”:“smil.xml”}],“date”:redacted,“i”:“9a118fc9-c617-4ec5-9718-929c133c1f44”

smil.xml is

SMIL stands for Synchronized Multimedia Integration Language

https://file.org/extension/smil

is your iphone on AT&T network?

next we ask why is RW anywhere app displaying your text messages in unicode?
don’t know. but it is a start.

No, my work phone is on Verizon. I am getting the same problem on my iPad with Anywhere: the iPad is wifi only and also shows the unicode instead of just the message.

As far as not getting messages on Google Messages, I lost a whole conversation from yesterday but today it seems to be working. I texted from my Google Voice and it showed up in Google Messages fine.

Still getting unicode in Anywhere on multiple devices. Note that all phone involved in the messed up or lost conversations are Republic phones except the iPhone.

open a help ticket there maybe other reports of this happening on apple products. maybe be something with the 12.1.1 update they just pushed out.

Hi @eleanorw,

For what it’s worth, I’m not sharing your experience. Generally, I use Republic Anywhere across devices, however, I switched my Republic phone to Messages by Google. I then used a second household phone (also running Messages by Google) to send a test message to that phone. That test message was received and displayed correctly via Messages by Google on the Republic phone and an iPhone running iOS 12.1.1 and Republic Anywhere.

So, to be certain we’re understanding correctly, this experience arose when one Republic phone sent a text message to another Republic phone. That message wasn’t received on the Republic phone using Messages by Google and was received in unicode on iOS devices running Republic Anywhere?

If I’ve got all of that right, I have some questions. Was the Republic phone sending the message running Messages by Google, Republic Anywhere or some other messaging app? Are your iOS devices running the latest version of iOS, which is 12.1.1. Are your iOS devices running the latest version of Republic Anywhere, which is 1.0.3(4). Are the messages in question SMS (plain text) or MMS (picture and/or group texts)?

As a test, would you be willing to install and use Republic Anywhere on your Republic phone to see if doing so changes anything on the iOS devices?

Close. I know this can be hard to follow.

Family chat. Wife and son on Republic Samsung Galaxies (s7 and s9). Wife using Anywhere current version. Son Google Messages. Me on iPhone 6/anywhere. All operating systems and apps most current for wife and me. Son? Don’t know for sure.

Messages came in with unicode on my iphone/anywhere. Everything normal for family.

I switched to my up to date republic Samsung using Google messages. Unicode. I begged family to switch to my Google Voice number.

The last few message when I asked them to move to my GV number appear on iPhone /anywhere but don’t show up at all on Samsung /Messenger.

Now today those old messages that were Unicode on messenger display properly. IPhone still shows Unicode.

Made anywhere on Samsung my default app just now. Everything displays fine there but the missing messages are still missing from messenger and Samsung /anywhere. They still exist on iPhone /anywhere as Unicode but they are there.

This is so odd that I’m not hopeful anyone will figure it out but let’s see! I really want Anywhere to work on iPhone when I’m in the office and I rant prefer messenger over anywhere on my personal phone. Just aesthetics but still.

Thanks for your interest.

Hi @eleanorw,

I’m afraid it is all a bit too much for me to follow. For instance. I’m not sure how/why the messages sent to your GV number were supposed to reach all the different phones you carry, and why, if they were supposed to, they didn’t.

Is the problem with the messages displaying in unicode persisting, and does it happen with anyone other than the family members in that group message?

I understand that this issue is confusing. Google Voice is not the issue at all, however. I only mentioned GV because that is my alternative to standard SMS. Google Voice has nothing to do with the problem. Republic Anywhere on Android works fine. it is only Anywhere on iOS… which is where I need it. Work phone that is my go to device when in the office.

The problem is that I am getting unicode instead of standard text messages on my iOS devices. But I have seen something new.

Individual SMS between me and each of the other two people seems to work fine. Group messages are still a unicode mess.

Thanks @eleanorw,

Do you get any group messages from other people? How are those?

Could you get your two individuals whose group messages are a mess to each (individually, not in a group message) send you a text message that includes both text and a photo?

Yeah… I don’t actually group chat with others. Just a family thing. I guess I just need to keep telling them to use my Google Voice for Group and/or switch to my Android phone when they forget. It is just so oddly specific to iOS and I don’t see others having the issue. But thanks for the interest and effort nonetheless.

I think I’ve now been able to duplicate this. What I’m seeing is if a Republic member using Anywhere on their Republic Android phone sends a group message to recipients that include at least one other Republic member, the Anywhere iOS app displays what I think is XML markup. All appears normal in Anywhere on the Republic phone.

Interestingly a picture message sent to a single recipient displays correctly despite this also being MMS.

Yes. That’s exactly what I’m seeing. At least it is good to know it isn’t just me! So for now Google Voice remains the best option for cross-platform/device messaging (even though GV sometimes just plain stops working for hours at a time with no apparent reason). Nothing’s perfect.

I logged a ticket for this October 14th and it was never solved. I am using a work iphone on Verizon. I believe the html like text are only occurring on my iphone app when I receive group texts from other republic wireless customers. It has not occurred when I receive a group text from others not using republic wireless.

By the way, when I view these same texts on my Windows PC or my own RW phone, the text appear perfectly normal.

Your diagnosis is correct. My experience is the phenomenon occurs when the message originator and at least one member of the group is a Republic member. It doesn’t matter what messaging app the Republic member originating the message is using. I’ve now tested originating the message with both Messages by Google and Republic Anywhere. It hasn’t yet been solved as this appears to be a bug either with Anywhere or an interaction between Anywhere and iOS 12.

The issue appears to affect Anywhere only on iOS. Anywhere on Android, Mac, PC and probably Linux (can’t vouch for it as I lack a Linux box to test with) is not impacted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer