Some contacts simply disappeared


I started a message this morning and went to search for an often-used contact and - nothing. Some contacts are still there but a number of common ones, like family, are gone. Don’t know how many. Manual sync with outlook calendar was successful. Tried syncing outlook contacts - nothing. Existing messages show phone # but no name. ■■■■. Moto G Plus, Android 7.0. “Messages”, updated 10/25/18, it worked since then. Also have WhatsApp, no names there either. Have Contacts ver 1.4.17, no data used. I also have a google acct, but don’t know where the contacts are stored. This ■■■■ phone pisses me off beyond belief sometimes.


Hi @dough.ok57u7,

It seems your first step might be to see where the missing contacts are stored, then you can focus on syncing from that source.

Contacts stored through Google are at - just sign in with the same Google credentials you use on the phone.

Info on accessing your contacts for Outlook can be found here:

Do you have any other contact sources that might have recently been removed from the phone? Facebook messenger? Yahoo?


When I create a new contact on the phone, it says it’s saving it to
my google acct.

I logged in to that google account online, there are 65 contacts,
far short of what I had.

I tried “Undo Changes” as of yesterday afternoon, still only 65
contacts on-line.

In google, I resynced contacts and People details.

Still no more than the 65 contacts.

I logged in to outlook online and found a bunch of contacts.

On Moto G, I tried to add an outlook account, but it says the email
address is already connected with outlook, do I want to connect it
again with another service?

Heck, I don’t know, I don’t think so.

Apps are Messages, ver 3.7.052, WhatsApp Messengerver 2.18.327;
phone is just the phone app.

I’ll never put FB or Yahoo on my phone, so, no, I don’t think any
other contact sources were removed.

Tnx, Doug.


Hi @dough.ok57u7,

You wrote,

You you tell us the exact steps you’re taking and the exact wording of the message? Maybe someone who uses outlook will have some additional insight.


Something similar happened to me last night after “removing” my Gmail account (accidentally). Now, all the contacts I’ve added since I got this phone don’t exist. I reconnected with the account, but the contacts don’t show up anywhere on the phone. They also don’t show up in my Google account on desktop. It’s as if all of the contacts I’ve entered for the last 4 years (since owning the phone) haven’t synced at all even though I know I had all possible syncing options checked. The Undo Changes option didn’t work for me at all.


Hi @roadbase,

Did you remove more than one Google account or any other accounts?


@dough.ok57u7 Did you ever figure out what happened with your contacts?


No, no idea what happened.

I didn’t (knowingly) remove any accounts, but who knows - if you touch a phone in the wrong place…

I’m just just adding the names as calls come in, it’s faster.

I would like to get my Outlook contacts on the phone, that would solve a lot of problems.



If your outlook contacts are connected to either or and Exchange server it is fairly easy to sync them to the phone using this app:


Thanks, I’ve got the outlook app and the calendar works, but no way
can I find anything about contacts.

I did find them on

How do I sync them?


I apologize, you’re right, it isn’t the Outlook app that’s syncing my Exchange contacts. This App does it for me however:


You can sync contacts via the Outlook App. It just doesn’t do it automatically. Go to Settings > Click on the Account > Enable Save Contacts. At least that’s what I did on mine for my work Exchange account.


I think my lost contacts on the phone are (miraculously) fixed!

I was in the Outlook app on my phone and went to edit an Outlook contact.

Got a message that I had sync my contacts before I could edit them, so I did.

All the contacts are now on the phone.

Per your instructions: “Go to Settings > Click on the Account >…”

There is “Account Sync” with and On/Off switch - it’s on, so I’ll check the timestamp occasionally to see if it auto-updates. (I’ll also manually update). There’s also a “Sync now” on a menu at that location. That seems to work.

Thank you much for your help - everything appears to be ok, although the process seems more convoluted than it needs to be.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.